1.5 Core Solo, 1.66 or 1.83 Core Duo, or 1.83 or 2 GHz Core 2 Duo processor

180 Questions View all

no usb

USB not working at all. mac fires up but not a peep out of the USB

tried plugging different USB devices in which have lights on them but doesn't seem to be power available

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

If one of these answers fixes your problem, please go to that answer and hit the "accept" so that we can remove the question from the unanswered list. Thanks so much.

by

Add a comment

3 Answers

Chosen Solution

According to what system you are running different IOUSBFamily are needed. You can look it up here for a detailed decription of the problem and which files are needed:http://developer.apple.com/hardwaredrive...

or

just reinstall your system and the updates.

Debug releases of the IOUSBFamily kernel extension are used to provide information about USB device and interface detection, driver and interface matching, driver loading and information generated as a result of normal and abnormal conditions.

Unique debugging versions of the IOUSBFamily kernel extension are available for the different Mac OS X releases. It is important that you install the correct version of the IOUSBFamily kernel extension or you might find that the system will panic during startup or that your USB keyboard or mouse may not function properly.

Was this answer helpful?

Score 4
Add a comment

Looking at the teardown guide the USB ports are soldered to the logic board. Therefor my first step would be to run disk repair. If that didn't help I would make sure I had a good backup--reformat the drive and reinstall the OS. If still no luck you may be looking at a bad logic board. I usually recommend getting an appointment with a Mac Genius for confirmation before buying a expensive part. Ralph

Was this answer helpful?

Score 2
Add a comment

If you go to /System/Library/Extensions/ do you see IOUSBFamily.kext ?

Was this answer helpful?

Score 1

Comments:

just looked in Extensions folder IOUSBFamily not there

by

Add a comment

Add your answer

mat will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 2

Past 30 Days: 3

All Time: 1,814