Mid 2006 / model number A1181 / black or white case / 1.83 or 2.0 GHz Intel Core Duo processor.

510 Questions View all

My battery wont charge, a new battery and different charger didnt help

13inc MacBook 1.83ghz A1181 Late 2006

I have late 2006 macbook that has seen better days, A wile back the battery stopped charging and gave me an X symbol. I have tried a new charger, new battery, PMU/SMC reset but nothing has helped. Im now looking into getting a magsafe dc in board or a new logic board. Anyone who's experienced this before have any advice before I go investing in this older but great laptop would be greatly appreciated.

Edit: Everything runs fine, I get the black X in the battery icon. When i shut it down, unplug it n plug it back in the charge light goes amber for a minute or two then turns green. Sometimes the light on my battery flashe but its completely dead from not charging.

I have also reformatted and installed osx all over again. I also went back to 10.5.x to install apples battery fix 1.4 (doesnt work on sl)

Battery Information (Battery installed):

Charge Information:

Charge remaining (mAh): 0

Fully charged: No

Charging: No

Full charge capacity (mAh): 0

Health Information:

Cycle count: 0

Battery Installed: No

Amperage (mA): 0

Voltage (mV): 0

Thanks

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

It stopped charging but does it run?

by

Is the X red or black?

by

i updated my info

by

Add a comment

6 Answers

Chosen Solution

Most of the times the problem is with the sleep sensor/charging board socket on the logic board. A little corrosion on one of the connector 20 pins or inside the socket female holes in the logic board can interrupt the charging functionality. Often this is happening after a liquid spill. Hard to repair if the problem is not the charging board. That means a logic board replacement.

Was this answer helpful?

Score 3
Add a comment

Here's what Apple says :

Symptoms

The battery of a MacBook or MacBook Pro computer may:

  • Appear to have no charge (zero percent)
  • Be unable to power the computer by itself; the computer might work only when it is connected to the MagSafe power adapter, which only shows a green LED
  • Appear with a black "X" icon on the menu bar

Resolution

1. Shut down, then remove and reinstall the battery. Test for the issue(s) again.

2. Connect the MagSafe power adapter (if you haven't already) and see if the behavior continues.

3. If the issue(s) persist, download and install the Mac OS X v10.4.9 Update.

4. If the issue(s) persist, download and install Battery Update 1.3.

Go here for Apples links to other solutions: http://support.apple.com/kb/TS1457

Was this answer helpful?

Score 2
Add a comment

After purchasing new battery and logic board, and still no luck, I tried one more thing. I have a MBP 13 inch mid 2009. I unplugged the battery meter board cable. This is right next to the larger block style battery plug. As soon as I disconnected, the black x disappeared and my battery started to charge. I have since replaced that cable with a new one, and everything is back working the way it should. If I went into settings, it wasn't even seeing a battery, never mind not charging it. I hope this works for you.

Was this answer helpful?

Score 1

Comments:

Can you explain more please because I have same problem ? which cable should be changed ??

by

Add a comment

Here is what solved this same issue for me

I bought a new cheap Amazon battery, and the MacBook A1181 2006 would not recognise or charge it.

I found the pinout for the battery and checked the battery voltage, it was down to about 9.8 volts and the lights on the back, only the first one lit..and flashed on/off.

If you put the battery down on the desk, as if fitted to the Mac, with the test button and lights down and the top of the battery up, with the battery connector slots pointing towards you.

First narrow one is Negative, last narrow one is positive

The pack is 3 lipo cells in series 2 in parallel (3s2p) configuration.

So, 3 series is maximum of 3 x 4.2volts = 12.6volts

I have a hobby charger for charging model aircraft batteries so can set it to 3 series and with a couple of bare wire ends stuffed in to the battery slots, take care to get polarity correct..then I gave it a 10-20 minute charge. This brought up the voltage to 11.4 volts or so.

At this point I put it back in the Mac and the mac now recognised the battery and it charged. Seems to charge for a bit, cut out, charge for a bit..I guess that is battery balancing happening on the built in BMS(Battery management System) PCB

Was this answer helpful?

Score 1
Add a comment

You need a new magsafe board.

Was this answer helpful?

Score 0
Add a comment

I took it to apple and they said the logicboard/ motherboard needs to be replaced....Just go on ebay and purchase an external battery charger for a1185 its $32. works for me :) good luck.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Chad Lodge will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 24

Past 30 Days: 63

All Time: 10,874