Model A1181: 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1377 Questions View all

Running OS-X 10.6.8 What can I upgrade to?

Apple site will not let me down load Maverick. I am running snow lepard what can I upgrade to?

Update (06/29/2014)

  • Processor 2.4 GHz Intel Core 2 Duo
  • Memory 4 GB 667 MHz DDR2 SDRAM
  • Graphics Intel GMA X3100 144 MB
  • Mac OS X Lion 10.7.5 (11G63)

Could I upgrade to Mouton Lion?

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

We need to know your exact machine and how much RAM you have. Please give us your serial number (located in the battery compartment).

by

Add a comment

2 Answers

Chosen Solution

Per Apple's TN: System requirements for OS X Mountain Lion. "MacBook (Late 2008 Aluminum, or Early 2009 or newer)" is supported.

Your system: Apple MacBook "Core 2 Duo" 2.4 13" Early 2008 (White or Black) as listed in EveryMac.

Sadly, the answer is No you are now running the highest OS this system can support (10.7.x aka: Lion).

Update (07/02/2014)

Sadly, no you can't run Mountain Lion. Lion is the highest.

Was this answer helpful?

Score 2

Comments:

The Core 2 Duos can run Lion (10.7). Snow Leopard (10.6) will also work

by

Add a comment

Dan - I was not disagreeing with the Lion part - just that Lion is 10.7, not 10.6.

10.6 is Snow Leopard.

Was this answer helpful?

Score 0

Comments:

I hate it when I put on the wrong fingers in the morning, too! :) The extra one could come in handy at times though.

by

Add a comment

Add your answer

joseph will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 14

Past 30 Days: 27

All Time: 2,688