Skip to main content

Not Charging. No light on Adaptor.

Dear Fixers,

My PowerBook doesn't charge. The light on the end of the Charger doesn't come on when I plug it into the computer. I have tried my old battery, which had a power on it, and the computer booted up fine. I tried a new charger but this didn't function. So I think it must be something inside. Perhaps the DC Board? What do you think?



PowerBook G4 12" 1.5GHz

Answered! View the answer I have this problem too

Is this a good question?

Score 1
1 Comment

Look on the back of your computer for a "A1xxx" number so we can be sure of what part you need.


Add a comment

1 Answer

Chosen Solution

I agree with you, the first thing would be to replace the DC IN port. Here's a link to how to do it: PowerBook G4 Aluminum 12" 1-1.5 GHz DC-In Board Replacement

Here's the part: [linked product missing or disabled: IF153-021]

Make sure of your model before ordering.

Was this answer helpful?

Score 2

1 Comment:

I tried putting a new dc in port on and it still doesn't work.

What would your next suggestion be?

I feel a little down hearted!


Add a comment

Add your answer

David Pagan will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 7

Past 30 Days: 8

All Time: 2,559