Mid 2006 / model number A1181 / black or white case / 1.83 or 2.0 GHz Intel Core Duo processor.

511 Questions View all

New 320GB hd will not work in my MacBook

My Macbook has a 60 gb HD. The drive went bad and I ordered a new WD 320gb drive. Install procedure was a snap, but the harddrive was recognized by the MacBook as a 2.3 TB drive. I followed procedure to format and name the drive, but was unable to format or install from the Mac install DVD. Also tried to start up and install from the Leopard DVD, with no luck.

When I called Apple, they told me that the largest drive I could install in the MacBook was a 120GB, which I cannot locate.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

I currently have a 320 GB replacement drive (I believe also from WD) installed in my Macbook Core Duo, and it worked just fine out of the box. I'm running Snow Leopard rather than Leopard, not sure if that's an issue.

by

Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Chosen Solution

The drive may be to fast. You may need to use the jumpers on the drive to slow it down to 1.5 GB. For the correct setting you can Google your hard drives name and "jumper", or give us the name and model number and LMGTFY. There were hard drive limitations on the old G4 machines from over 10 years ago but I've certainly not heard of any on the MacBooks. Also please give us the last three figures of your serial number.

Was this answer helpful?

Score 2
Add a comment

Add your answer

Jim will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 402