Black screen after replacing flex cable. [SOLVED]

[THE PROBLEM]

I ran into an issue in the shop where after replacing the Flex cable every screen I tried was black. The iPod wouldn't even beep when plugged in.

Since I googled the tar for a solution, and couldn,' find one, I'll post what I found for anyone else with the same problem who hasn't been able to find a solution.

The solution is moved below, to the answer so that it can be cleared per request.

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

Please use the last paragraph as an answer and accept it to clear the question.

by

Thanks for letting me know guys, I did as you suggested.

by

Add a comment

2 Answers

Chosen Solution

[HOW TO FIX IT]

I covered the circuits around the flex cable and de-solder it then cleaned up the pads and soldered on the new flex.

Not adhering to my own soldering instructions, of course I got in a rush and did this without de-soldering the + terminal on the battery first.

In my case, I went back and disconnected the + terminal on the battery and soldered it back on. The black screen went away and the iPod kicks up just fine.

I hope this helps fellow techs that may have found this.

Was this answer helpful?

Score 3
Add a comment

Hi there,

having a bit of trouble with an iPod touch, after multiple screen replacements it's finally gone black. I've tried re-soldering the flex cable + battery however no luck. Boots fine and connects.

Any insights?

Was this answer helpful?

Score 0
Add a comment

Add your answer

Country Computer Service will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 3,197