Repair and disassembly guides for Apple Time Capsule wireless network devices.

118 Questions View all

front light went out

front led stoped working but timecapsule works fine.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

I have the same problem, how can I fix it???

by

Add a comment
Deck the Halls
With tools and Fix Kits

4 Answers

Chosen Solution

The average life is about 18 months. If your computer is under AppleCare take the Time Capsule in for replacement. I read on this for about an hour. Main problems seem to be overheating and bad capacitors. There are instructions on replacing the capacitors on some sites. It's a very well know issue. Back up to something else in a hurry. Here's just one of the Apple threads on it. http://discussions.apple.com/thread.jspa...

Was this answer helpful?

Score 1

Comments:

Good to see you here Mayer.

by

It wouldn't still be working though, if you read the question, your answer does not apply, it's a simple LED issue, the drive mechanism works fine.

by

Add a comment
Most Helpful Answer

To be clear, is your time capsule functioning properly? Or do you just hear it running but it is not responsive or recognized on the network? The following would apply IF the Time Capsule front LED is not lit when plugged in, but you can hear the fan and possibly the drive attempt to spin up (usually never achieves full "throttling" speed for normal use under this condition.

The probable Issue: (Anecdotal) One of my time capsules, in between being moved physically and unplugged, refused to function properly after being plugged back in. The LED light would not turn on, the drive would audibly spin, and it was never recognized (networking, plugged in, etc).

The Problem Diagnosed: After some testing, was the breakdown of solder joints (much the same as some of the old macbook pro logic boards with GPU issues, etc). The joints had broken (microscopic breaks) and were not totally functioning in every spot. Because I don't have rework equipment (have to ask to access it and I don't like asking for favors), I decided to try a home remedy on something I knew was dead and didn't mind if the attempted repair didn't work.

Method: Completely disassembled the time capsule, and stripped down the main PCB (printed circuit board)... stripped free of any soft plastics, tape, etc (anything that would melt or burn under heat). NOTE: There's a clip on the back of ports that is a plastic locking clip... you wouldn't notice it unless you're looking. BE SURE TO REMOVE THIS. It would melt under heat and ruin the inside of the ports.

After you're sure you've removed everything, clean the board with a toothbrush or some other very soft bristled brush and soapy water. You could use 90% rubbing ETOH, and then soapy water, but I don't think it's necessary. Clean the board off thoroughly - but gently.

(NOTE - I have to go to shop to use rework equipment and it's a bit of a hassle --- I usually save up a number of boards to work on and do them in a period of a week or so, so I attempted this method with the knowledge that this could damage the board)

PREHEAT a kitchen oven to 395 degrees (use a good oven that maintains the temp well... not a cheapy in some rental apartment that will fluctuate. This part is important, and I can explain why chemically if you want to message me). Prepare a cookie sheet or something similar with a sheet of aluminum. Make a couple of balls with additional aluminum. Position the PCB ("processing chip" faced upwards) on the balls (or "support pillars), being sure not to position the balls touching plastic parts. Contact of the aluminum balls with small plastic ports will likely cause them to melt. The idea here is to be exposed to even heat all over, making as little direct contact as possible with heated surfaced. You want the ambient heat, not contact heat. The same could theoretically be achieved with a quality heat gun, but most people are not talented enough to apply even heat for a duration -- even myself (although I've used my hako heat gun - a rather expensive quality model -- plenty).

Put the tray with the PCB positioned properly in the oven (once preheated), times exactly for 8 minutes. No more. You could play with less if you were wanting to be super cautious, but it might mean assembling and disassembling multiple times. I've tried this a number of times with failed PCBs from broken solder joints I could only spot with infrared. This is my "best practices" method.

After 8 minutes, carefully remove the tray (steady handed... you don't want the PCB to shift off the pillars, or roll off and touch the tray. It will burn the board). 10-20 minutes later, when you're sure the board has cooled, reassemble the parts back to the PCB, and then reassemble the time capsule.

It should work if you're careful. NOTE: This COULD potentially help a dead board as well, but this suggestion is primarily targeted for boards like mine that showed they were successfully powered, but not functioning properly (and thus, the time capsule not functioning).

Questions?? Post here, and I'll answer. Cheers

Was this answer helpful?

Score 3
Add a comment

First suggestion would be turn it off, wait 30 seconds, and turn it on again.

Does the internet connection still work fine?

Was this answer helpful?

Score 1

Comments:

LOL... always forget to mention the obvious. Thanks Rab.

by

Add a comment

WORKED LIKE A CHARM! AM WELL CHUFFED! Wondering what other things i can bake back into life now... pretty sure my old crucial m4 ssd must be worth a shot ;)

Was this answer helpful?

Score 0
Add a comment

Add your answer

johnJess Mabrey will be eternally grateful.
View Statistics:

Past 24 Hours: 7

Past 7 Days: 58

Past 30 Days: 176

All Time: 9,294