Originally known as "The New iMac" the iMac G4 was created to replace the iMac G3 as Apple's all-in-one desktop computer. The G4 is easily recognizable by its swiveling monitor mounted above the hemispherical computer. Steve Jobs quoted it as being "a design that will last till the next decade."

129 Questions View all

iMac G4 making loud beep after optical swap and Tiger upgrade

Hi! I replaced a customer's dead Superdrive in an iMac G4 1GHz, wiped the hard drive and upgraded him to Tiger, and threw in an additional 256MB, for a total of 512MB. I also installed an Airport card, connected to my wifi, and updated the machine to 10.4.11. I used it for two days after the procedure, and all seemed fine. He's telling me that yesterday he was using the machine, and it make a startlingly loud beep, and showed text on the screen, and he had to kill the power to get it to stop. Today he tried running Software Update, but in the middle of the process he got the "you must shut down" box. I told him to reset the PMU and PRAM, and it seems stable for now, but I'm not feeling so confident. If he calls back I think I'll have him pull the additional RAM I put in, and reset the PRAM three times.

Any ideas as to what I could have done wrong? Thanks in advance!

John

Answered! View the answer I have this problem too

Is this a good question?

Score 2
Add a comment

3 Answers

Chosen Solution

I don't think you did anything wrong. It sounds as though he's getting kernel panic. Usually the first thing I would look at is the extra ram you installed may have worked a little loose or is failing. I would try removing that ram first. The single beep also makes me think of ram. Ralph

Was this answer helpful?

Score 2

Comments:

Thanks Ralph! Yeah, that was my thought too. My only other idea was that the guide I used recommended re-applying thermal paste when opening the machine up, which I didn't do (the existing paste appeared intact), but like I mentioned I used it for two days with no problems, so it seems unlikely it would be overheating.

by

Add a comment

macs are good for that warning instead just blowing up!

Was this answer helpful?

Score 0
Add a comment

If the RAM slot you used was empty before, it could well have oxidised contacts and be full of dust etc. I would reseat all RAM twice before reassembling. If this doesn't fix it, I would suspect faulty RAM. If you suspect overheating, you'll need something to excercise the CPU. I've had one of these fail when applying OS updates purely because the fault only came out when it was working hard.

Was this answer helpful?

Score 0
Add a comment

Add your answer

rdklinc will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 2,703