Released on July 21, 2011. Core i5 or Core i7 Processor. Thunderbolt. This unit is also used to run the Mac Mini Server configuration.

167 Questions View all

Fan stuck at full speed

I have a 2011 mac mini and went to do the second HD upgrade, and ever since the CPU fan is stuck at full speed.

I have tried to reset PRAM and SMC but i cannot tell if they have actually reset, not sure if the sandy bridge based macs use something different.

I also ran the "d" diag utility and everything passes. The machine runs fine the fan is just stuck at 100% and its very annoying.

Answered! View the answer I have this problem too

Is this a good question?

Score 4

Comments:

Kyle, Jeronimo,

I now have exactly the same issue. Everything works great apart from the fan at full speed! Did you have any luck in fixing your machines?

Thanks,

Andrew

by

Add a comment

9 Answers

Chosen Solution

It sounds like you may have a faulty sensor. Your unit should still be under warranty and I would take it to Apple and let them fix it for free.

Just noticed you did a hard drive upgrade so Apple would probably not cover your problem. Please go over the steps in your upgrade and see if you missed a sensor.

Was this answer helpful?

Score 3

Comments:

I just went through the guide. is there anywhere i can specifically look for a sensor?

how can i completely tell if the SMC reset has worked?

by

I just replaced my HDD with an SSD on my 2011 mac mini. I reassembled it after installation, and the fan went full blast, and wouldn't turn off.

Sure enough, I forgot to reconnect the hard drive thermal sensor. Since there's no signal from the sensor, my guess is that it will default to full speed, for safety. Hope that helps.

by

Add a comment
Most Helpful Answer

The "missing" componet is the thermal sensor, which is attached to the stock hard drive. When you take the stock hard drive out you will see that there are two connectors - the main hard drive connector and another, thinner connector. The wires for that thinner connector are stuck to the side of the hard drive with the plastic "cover". A cursory glance will make you think those wires are just part of the hard drive, some superfluous connector that it appears you don't need, since the SSD works fine with just the main connector attached. They are not superfluous. And those wires don't actually go into the hard drive either.

If you have a look at step 21 of the Crucial SSD installation guide (http://guides.crucial.com/Guide/Mac+Mini...) you will see that the thermal sensor is just softly glued to the hard drive, probably because that's the thing that would tend to get the hottest when the system is working hard. All you need to do is pull the plastic "cover" off and then gently peel off the sensor from the hard drive. Then you can plug the sensor back in to the appropriate socket on the main board and run the sensor to somewhere where it might get hot. I just ran mine up near the RAM and now my fan works correctly.

Was this answer helpful?

Score 5

Comments:

That's an amazing find! I was wondering what that extra lead on the old HD was all about. Prayed it off and will attach to the new SSD. Hoping that will do the trick.

Thanks!!

by

FYI: Crucial's guide is a copy of the IFIXIT guide. Here's the IFIXIT guide: Mac Mini Mid 2010 Hard Drive Replacement

by

Thanks for this tip; we had a mini with 2 HDs but didn't need them both. Pulled sensor off second drive and attached to the first (only HD needed) and worked like a charm. I assumed since I didn't have an optical or second HD that I wouldn't need the sensor in place...

by

Excellent advice - very smart! Thank you very much.

by

Add a comment

Kyle,

One thing to check is the print manager. Sometimes the CPU gets stuck on trying to print to an unconnected printer.

Go to

Finder> Utilities> Activity Monitor

Select display all processes

Find the process taking up the most CPU % and kill that process.

The fan speed should drop within seconds.

Let us know.

Frank

Was this answer helpful?

Score 3

Comments:

fan spins to 100% immediately on boot. and stays at 100% i just cleanly wiped the mini same results.

just did the in depth diag test and got the following result:

4m0t/1/40000003: Exhaust - 6653

my main concern is i voided the warranty, im not sure where to go with this now. i work on machines all day long (im a win server admin, and have been for years)

i would consider replacing the exhaust fan part: 610-0164 but i cannot find it anywhere.

by

I found that every time I want to my Mac mini 2.5Ghz 16GB that it was hot and the fan was on full. Just followed Franks advice and found that the Google Drive app was at 96% of my CPU capacity. I killed the app and the fan slowed down with about a minute and within 2 mins all was quiet. Thanks for the tip Frank

by

Add a comment

I had this fan spin issue on my older core 2 duo mac mini, after installing an ssd. I solved this by replugging the fan in proper orientation. I must have turned it around during reinstallation.

Possibly this is a solution here also.

Was this answer helpful?

Score 3

Comments:

I had this problem after change my hdd and the problem was the connector for me too.

by

Same issue after replacing the HDD with an SSD. The issue for me was a tiny little wire that went into one of the sensors had come out just a bit, enough to break the connection. After using needle nose to slip it back up into the clip the fan worked fine. Also note that the CD and HDD sensors are the same size and approximate length. It seems possible to swap the two accidentally. Good luck.

by

Add a comment

I have resolved my fan issue. A surface mount component had somehow come off the logic board and as a result the (pwm) fan control signal was not controlling the fan. The fan defaults to full speed when it sees no pwm signal. I was able to see the (monitor) signal was working by using smcfancontrol and the slowed the fan with my finger - the rpm changed. As a result the mac was requesting, for example, 2000rpm, but as the fan didn't see the request it was giving approx. 6500rpm, hence the error code. The missing component was a bridging SMD device. By hooking up an oscilloscope I could see a pwm signal on one side of the missing bridge, but no signal at the fan. As soon as the 2 pads were bridged normal service resumed. Not sure how this component has become detached, presumably when I removed the fan connector.

Anyway, it is worth checking for 2 solder pads just above the fan connector - if you see no component then you may have the same issue!

Was this answer helpful?

Score 1

Comments:

@aac197, can you post a picture of your jumper wire and the pads that were jumped? I'm having the exact same problem but I don't have an oscilloscope. Thank you!

by

Thank you AAC197 for the tip about the little smd component just next to the fan connector, somehow it got unsoldered and there was no contact, there are 3 components, and the one close to the fan connector was the issue. I checked with my multimeter and there was no connection, it seems to be a little diode or something because checking continuity after fix there was no resistance, one of the fan pins goes through it. Thank you again, also I had this SSD fan control application that did not work until I got this fixed.

== Update ==

My board had 3 connector for the sensor's, 1 was for the hd temperature, DVD temperature, and 1 for ambient temperature. If you don't see 1 it is probably broken take a good picture of where the fan connector is at surrounding area, and I could point you where is it supposed to be.

by

same issue here, but i can't find the component. How can i solve this? Just bridge the connection?

thanks for your help

by

Hi Step I checked, with my multitester and it seems it is not a diode, measured resistance on it and I got 0.4 ohm resistance, my multimeter shows 0.2 ohm resistance if nothing is on the way. It can be a smd cap but not sure, I wish I could help more.

by

Hi, When I had this problem, I gave it to a friend of mine with a full electronics workshop in his garage. Using an oscilloscope, he was able to see the fan control signal on one of the solder pads of the missing component. He was then also able to see that the other solder pad was connected to the fan control pin of the fan connector.

He then measured the impedance of the fan control circuit of the fan and the motherboard and was able to deduce (based on similar low voltage fan controller designs) that the missing component was either a low or no voltage jumper component.

As such he then just bridged the two pads with small piece of wire and my mac mini has been working flawlessly for 2 years now!

As Lui has measured this to be 0.2 ohms, I suspect that what has been done to mine is absolutely fine. My friend doesn't believe that this component would have been a capacitor.

Hope this helps!

by

Show 7 more comments

Add a comment

I downloaded a fan control program from http://www.crystalidea.com/macs-fan-cont... and it has worked well so far. My problem when I pulled off a socket from my board when removing the plug attached to my optical drive thermal sensor while replacing the battery.

The sensor program allowed me to choose among different sensors by listing their current operating temp and what component they were sensing.

Was this answer helpful?

Score 0

Comments:

Sadly, the software solution is not a good long term fix. Over time you will wear out the fan bearings and/or shorten the systems lifespan. There are people with micro soldering skills that might be able to fix the damage. I would recommend you give them a try.

by

Is this your opinion or experienced fact?

The web site that led me to this software also offered that apple had a fan control app, that did the same thing , but it was developed for the iMac which employs more than 1 fan and therefore wasn't ideal for the mini. The forum is on Macgurus.com. The software I suggested has been used since at least 2013 on both macs and pcs with no negative feedback I could find. If you know otherwise I am interested. For the time being I am watching the included temperature samplings and fan speed analog while I decide on soldering equipment to tackle the job myself. I have some experience soldering communication cables for our earlier years of networking CNC machines with our engineering and programming departments.

I am also aware that some companies build fixes into their systems but don't necessarily advertise them so that they don't have to employ highly trained technicians to repair their products.

Thanks

by

Sadly, from experience working on Mac systems over 20 years this band-aid solution is not ideal. Between burnt out fans & systems it is a costly venture over the long haul. -

Apple fan control is via hardware (SMC services) which works via the core OS (and not controllable by the user). Apple does not offer any fan control application to access it. Apple uses thermal sensors and tachometers built into the fans to monitor both the temp of different things running in your system and how fast the fans need to run to remove the heat buildup dynamically. I would recommend you use a good monitoring app that allows you to see visually what the sensors and fans are doing. I like this one: Temperature Gauge Pro. While it also allows you to set the fans I discourage its use for that. Instead see what sensor and/or fan are doing so you can then address the correct repairs the system needs.

by

thank you. I re read the forum I mentioned above and found that I had misread the part about apple. I will try the program that you suggested in order to compare it to the info my program is giving me, however I am still looking at soldering stations. I guess I am so used to 5 year obsolescence using PC's that having a system that is still useful at this time makes me brave about digging into it.

by

Before you warm up the soldering station, first figure out what you need to fix. Often the issue is just a loose wire (connector) or a damaged part.

by

Show 2 more comments

Add a comment

Macmini 2012 with SMC Fan Control and iStat menu monitoring fan speed and temperatures and it locked into 5,500 rpm today and would not quit. I removed the plastic base while stilled plugged in and running and was shocked to find a thick layer of dust similar to the lint you'd find in a clothes dryer covering the perforated metal screen. I removed the dust by hand and sprayed the rest with compressed air and the fan speed dropped to normal immediately.

Was this answer helpful?

Score 0

Comments:

You should plan for a yearly clean up dusting out your system. You also may want to look at where your system is. Do you have a shedding dog or rug? Do you tend to run the vacuum around a lot? You maybe need to address the area as well.

by

I also don't recommend using fan over-ride software as time has proved they end up doing more harm than good!

by

Add a comment

My 2010 Mac mini server fan speed 5xxx RPM is solved by swapping temp sensor soket between the 2 HD after a overheat shutdown problem and showed a exhaust reading error. Software fan control can help you diagnostic problem and temporary solved it by a fixed RPM, however it may damage your system while it is stopped to work and your system will be overheat w/o noticed fan is out of work. Also it would have occupied your CPU heavely, you should stop it(remove it from \Libary\App...) while you don't need it. Try to fix temp sensor first while you have a noise fan.

Was this answer helpful?

Score 0
Add a comment

I have a similar problem. The fan "revs" and then slows down. After about 9 seconds, it revs again. I tried a restart and that helped temporarily. Do I need to replace the fan?

Was this answer helpful?

Score 0
Add a comment

Add your answer

Kyle will be eternally grateful.
View Statistics:

Past 24 Hours: 25

Past 7 Days: 154

Past 30 Days: 336

All Time: 31,021