Released in 2003, the iBook G4 replaced the iBook G3 as Apple's portable consumer computer.

705 Questions View all

Battery does not accept charge

When charger is connected, the light starts green ,but then changes to flashing red and no charge is taken. Two batteries have been tried with the same effect.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

We need to find out how fast the iBook is so we know which version you have

To do this, click on the apple logo, then about this mac and add the speed to the "device" section or make a comment and it should be done, or used in refrence

by

Add a comment

2 Answers

Chosen Solution

This problem has been discussed before--link provided to previous post. Good luck.

G4 cannot charge or detect battery

Was this answer helpful?

Score 3
Add a comment

iBook is 1.2Ghz G4 A1054 Can't get it to start anyway. Nice to know it is a known problem! I have tried resetting the power management, (shift/alt/ctrl+power) and managed to fire it up for a short time. Unable to repeat this, neither battery having enough charge.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Roger Kennett will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 307