I replaced the battery but its doing weird things

The battery on my iPhone 7 plus swelled (it wasn’t original ) I bought a replacement and I changed it following the amazing step by step here. At first, it wasn’t charging, even though it was showing as it was, the percentage still the same, then it started to do some funny things like draining the battery, taking hours to charge only 20%, going from 83 to 20 in a minute, and then it was impossible to use as it was restarting all the time. I thought something wasn’t connected properly or maybe I damaged something when I replaced it, I tried many times but it was doing the same. I put back the old swelled battery and it was fine, so I realised the battery was faulty, so I’ve got a new replacement and its doing the same…. the only difference that I can see between the new replacements and swelled one is the APN number being 616-00249 and the old one 616-00250 but i’m not sure if that has anything to do with this problem…

Answer this question I have this problem too

Is this a good question?

Score 0


where did you get the battery from? does it show maximum capacity in the battery health tab in settings?


did you get the new replacement from the same supplier

if so send em both back

I've bought from Ifixit there batteries work fine



I bought it online from a shop here in New Zealand. No, it doesn't show it. When I go to battery health stays there thinking and thinking until it restarts again... Nothing of this happens with the swelled battery..


@sol_portanova I wonder if it's a defective battery


Add a comment