Model A1225 / Mid 2007 and Early 2008 / 2.4, 2.8, or 3.06 GHz Core 2 Duo processor

445 Questions View all

Diagnostic LEDs OK but no power

My customer's iMac is not booting at all. When the power button is depressed, the optical drive makes a sound as it resets the optical part, diagnostic LEDs 1, 2 and 3 light up (the LCD is currently disconnected), and nothing else happens. The hard drive does not spin up, no fans start, nothing. I've tried starting it in Firewire target mode but that doesn't work. I tried resetting the PRAM and the SMC, but no results. The customer took it to the Apple store and they determined that the logic board and power supply must be OK, probably based on the 3 diagnostic LED's and said it was most likely the LCD. I don't buy that. Even with the LCD disconnected, I think it should be booting. Am I wrong about this? When searching the Interwebs, I can't find any pinout voltages for the power supply so I don't know what to test for there. Any ideas based on your experience?

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

4 Answers

Chosen Solution

Hook up an external monitor to help isolate the problem and let us know your results.

Was this answer helpful?

Score 3
Add a comment

Hey did you get to the bottom of this? I have exactly the same problem? same symptoms, I wouldn't expect the LCD to have gone either but I've taken the thing apart and inspected the PSU and mobo and they both look fine. No scorching, no busted capacitors nothing.

Would really appreciate it if you have any further insight.

Was this answer helpful?

Score 0
Add a comment

Just Curious if there was a solution found yet? Mine is having the same issues

Was this answer helpful?

Score 0
Add a comment

im in the same boat. had the logic board and the psu out without any signs of damage.

Im tempted to check the PSU power outputs as per this guide iMac Intel 20" EMC 2210 Power Supply Output Voltage Test

ive got a DP to vga on order so will see what i get with that.

odd thing is i dont get the chime on boot. but the hard drive does spin up.

Was this answer helpful?

Score 0
Add a comment

Add your answer

powerbrixx will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 1,131