Skip to main content

Model A1419 / EMC 3070 / Mid 2017 / 3.4, 3.5 or 3.8 GHz Core i5 or 4.2 GHz Core i7 Kaby Lake Processor (ID iMac18,3) / Retina 5K display. Refer to the older iMac Intel 27" Retina 5K Display (Late 2014 & 2015) guides as the system is very similar.

130 Questions View all

CPU Upgrade Issue - No power

I decided to upgrade my 2017 iMac 27 in two parts this weekend: NVMe and SSD first, then CPU.

First part: 970 EVO NVMe with heatsink installed. Recognized @ Link x4 and great speed. SSD installed and MacOS Catalina reinstalled. Very happy so far.

Second part, a day after: Removed CPU, installed i7-7700k. Struggled a bit with heatsink like everyone it seems. But once done I felt confident that everything was done right, so I re-assembled everything. But the power switch didn't trigger anything!

  • LED 1 is on as soon as I connect the iMac to the external power cord.
  • Power switch cable seems intact and connected to PSU. PSU and logic board cables all disconnected/reconnected with great care and seem intact.
  • Tried to short both power switch pin to start up the Mac. Nothing happened.

Block Image

Does anyone have any suggestions or comments on what the problem may be?

  • I've ordered a new PSU for safe measure. I can't find a spare power switch button (the only part available that has it is an entire empty housing!).
  • Can't find a spare power supply control cable (between PSU and Logic board) for a 2017 iMac. But there are some for the 2011-2013 iMac which looks the same as for the 2017 version.

Tempted to order that. Does anyone know if the 2013 and 2017 use the same power control cable?

After discussing with friends, one plausible explanation could be that my CPU upgrade went bad. Such as static electricity frying the Logic board. Or the CPU is bad. Even though I've been careful all the way. However, if I understand the explanations regarding the logic board LEDs function, it seems that not even having the LED 2 or 3 on would mean my issue isn't yet entirely related to the Logic board or the CPU. Anyone can comment on this?

I would be very grateful for any suggestions (at least it'll boost my morale, as right now if the new PSU doesn't work, I would have probably to sell the iMac for parts!!)

Thanks

Seb

Update (10/15/2019)

Just received the new PSU (see picture). Installed carefully (making sure I discharge any static electricity from my hands prior). Reconnected all wires, after inspecting them (see picture). And unfortunately I have the same result: the power switch, which seems to be 100% intact (see pictures), doesn’t trigger any response. Fan doesn’t spin. No second LED.

Block Image

Block Image

Block Image

Block Image

Could it be the main power cable socket (buried under the bottom bezel of the imac housing)??

Any suggestions welcomed!

Update (10/15/2019)

Disassembled the Mac again. Look very carefully for damaged cables, or sockets… None found! Took a picture of the wires coming from the main power socket (see below). Everything looks fully functional.

Could this be a back Logic Board??

Block Image

Update (10/16/2019)

I can finally breath: Removed the new CPU, installed the old CPU and I’ve got the board to boot up. Did not perform a full reboot with the LCD on. I will make another attempt at upgrading tomorrow with another CPU, so I had only the PSU and Logic board mounted.

Is this a Bad CPU or it wasn’t mounted right, I can’t say for sure. But the Fan started to spin at max speed without stopping, so that got me thinking and decided to go for the i7-7700 instead of the 7700k!

Now, I got to improve my tension spring loading technique. I concur with others that the tension produced by this spring is excessive (Judging from the residue of thermal paste which had been completely squeezed out to the sides when I removed the CPU). So I’ve kept a more important gap between the mounting spring and the logic board, than what I had originally measured (<1mm). See pictures.

Hopefully my next post will be about completing this job… Wish me luck.

Block Image

Block Image

Block Image

Update (10/17/2019)

Final update: Finally got the system to work.

How: The short answer is you have to unbend the metal spring underneath the CPU!

There is way too much tension in this spring, this put so much strain on the CPU that it bends it. Some pins are then no longer connected. When the LED 1 or 1-2 lit up and nothing more it just means that.

I’ve tried a i7-7700k twice, reinstalled the i5-7600, then tried and kept a i7-7700 finally. So I’ve got plenty of trials to figure all this out.

I will now answer questions :)

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

Android Fix Kits

A new screen or battery is one kit away.

Shop Now

Android Fix Kits

A new screen or battery is one kit away.

Shop Now

1 Answer

Chosen Solution

Sadly, you need to roll back your CPU to check your logic board. I suspect you either have a bad chip or in the process you damaged one of the socket pins or lastly, mis-aligned the chip.

Was this answer helpful?

Score 2

Comments:

I was actually thinking of doing that. Just removed the Logic board and been staring at it for while.

Tightening the heatsink on this board was not trivial. Can the logic board pins be visually checked for damage, and what to look for? Mis-aligned seems impossible as you have two notches that would prevent it, correct?

--- Would love to have a bad chip. But 1. I may have touched the CPU's underneath and 2. When trying to screw the heatsink the spring plate underneath the board was sliding in all directions. Will post again when I re-install and test the board. Thanks for your prompt reply.

by

@danj Just posted an update above!

by

Reduce the amount of thermal paste! You only need a little bit so a film across the whole chip surface is covered.

by

Thanks Dan. Yes, I figured that out. It gets all squished to the sides everytime. So i've used less and less.

by

Add a comment

Add your answer

Sebastien Cadet will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 11

All Time: 57