Skip to main content

Fix Your Stuff

Right to Repair

Store

A1418 | EMC 2889 | Late 2015 | 1.6 GHz dual-core Intel Core i5 or 2.8 GHz quad-core Intel Core i5. Released October 13, 2015.

30 Questions View all

Hard drive upgrade not working?

iMac 2015, 8Gb, 1TB. Running Mac OS X Mojave. Used iFixit hard drive upgrade kit with Samsung 860 Evo 1TB SSD.

Opened in 10 minutes, disk pout in 5. Toughest bit was getting the new adhesive strips fitted - took ages to line up!

Now the tough bit.

I had cloned the drive, had to format as APFS, as when I did it as Mac OS Extended (Journaled) didn’t boot, and so I had to redo the clone.

Boots fine from USB port, bit when in the iMac, won’t boot - instead I get a folder icon with “?” in the middle. Reinstalled Had drive, and it went fine, so no probs with iMac. Also, rebooted from SSD with no issues.

Tried in iMac again, still no luck. Now back with Hard disk, and screen held on with tape.

What to do?

Answered! View the answer I have this problem too

Is this a good question?

Score 2
Add a comment

The Essential Toolkit

The most helpful tools in our most compact kit.

Shop Now

The Essential Toolkit

The most helpful tools in our most compact kit.

Shop Now

1 Answer

Chosen Solution

Cloning pretty well went out with the advent of the repair partition.

Todays method is to do a clean system installation (which gives you the repair partition. Now use Migration Assistant to move your data to the new drive.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Stephen Babbage will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 8

All Time: 115