Skip to main content

Second generation of iPhone. Model A1241 / 8 or 16 GB capacity / black or white plastic back. Repair is more straightforward than the first iPhone. requires screwdrivers, prying, and suction tools.

1505 Questions View all

Get beyond apple logo (which is only seen when plugged into charger)?

I was given a broken iphone 3g which had "stopped working" according to the previous owner.

The only thing it does to show life is to display the apple logo briefly, when plugged in, but only to the wall charger. (XP laptop doesn't recognize it, even with a fresh install of itunes.

I noticed lots of lint in the dock connector initially, which I cleaned out with a paperclip. Then I used some 90% alcohol with a toothbrush to clean out the dock connector socket.

I've tried recharging for a while, restoring via itunes (not recognized), and entering DFU mode (no luck.)

The best I've gotten was the 'connect to itunes logo' after I disassembled it to test the battery (good with 3.7v across the larger, outside contacts) and further inspect and clean the logic board and dock connector.

I'm not sure what else I can do. I'm tempted to spring for a new dock connector. Interested in the your opinions and suggestions for further troubleshooting.



I left the iphone on the wall charger for ~3 hours, and found the following link to similar problem which described how to get to DFU mode in a slightly different way than I was trying.

zero response from iPhone

I'm now able to download latest update from itunes (36 mins to go) so hopefully this will work, or else I will get an error and try iRecovery. Fingers crossed

Answer this question I have this problem too

Is this a good question?

Score 1


To be clear: the apple logo I'm referring to has no movement. I've only been able to get the "connect to itunes" arrow image the once, and only via the wall charger.

I've never seen a battery charge indicator.

Itunes, XP, and iRecovery don't recognize that an iphone is connected when I plug it in.


Restore failed with 1601 error.

iRecovery initially didn't recognize that an iphone was connected, but now does, however gives me the following error:

Found iPhone/iPod in DFU/WTF mode

usb_claim_interface: could not claim interface 1, win error: The parameter is incorrect.

Closing USB connection...

gonna try again. Positive part is that I can get into DFU mode.


I'm sure you've looked at this link for troubleshooting but you mentioned xp.. So it's worth a shot.


Thanks, yeah, I've tried many of the steps (delete apple products, reinstall, updates, etc) in that link. Just finished trying on my work pc, and same 1601 error. I'll keep trying.

There's a log of people with this error apparently, so hopefully someone found a solution.


So retried ireb with the instructions on the link. Same behavior: starts the extract, then I hear the USB/device disconnection tone on my laptop, and the progress bar changes from solid to a candy cane like stripe, and a while later error 1601...



Show 2 more comments

Add a comment

Android Fix Kits

A new screen or battery is one kit away.

Shop Now

Android Fix Kits

A new screen or battery is one kit away.

Shop Now

2 Answers

Most Helpful Answer I know this says iPhone 4 but it's about fw4.2.1 which you may have updated to

this article also mentions tinyumbrella, ireb...

Was this answer helpful?

Score 3


Thanks for the link. I don't see much different in what I've been trying already (used iReb last night.) I'll try again and report back.

by go down to the last few posts.

You could try a new dock as the common response is that its a usb communication error. change usb leads, ports, uninstall itunes, reinstall itunes, create new account... try another computer, remove ipsw to a different folder so itunes has to download the latest fw.

from macrumors

Unknown Error 1601, 1602, 1603

Problem during the Restoration

Solution: Uninstall iTunes completely and service Apple Mobile Device (With software Ccleaner )

Reinstall iTunes 7.5 or later.


Did you try restoring with fw from this site instead of from your iTunes library?


hey pollytintop, I used alternate firmware (ispw) from iclarified, I think. Same stuff tho. Same behavior.


I tried the oven reflow on a dif board- no change! It's worth a try but temporary at best. I sold my board with error 23 before turkeys post- so can't with resolder tips! He's got more tricks up his sleeve...


Show 14 more comments

Add a comment

Thanks for the answering and cleanup of the previous comments/answers:

I've made some form of progress:

I can plug the phone into my laptop and now get the apple logo for a few seconds

I can put the phone into DFU mode, start the standard restore via itunes (ie, not shift-click restore), and now get a 23 error when restoring. This gets this screen from black to lit but blank.

This leads me to believe this is a hardware problem, hopefully just the dock connector, which I've ordered a replacement for.

Now when I try to use irecovery after the failed itunes restore, I get the following:

iRecovery - Recovery Utility

by westbaer

Thanks to pod2g, tom3q, planetbeing, geohot and posixninja.

Found iPhone/iPod in Recovery mode

Radio failed to respond.

Radio failed to respond.

Pinging Radio Failed, 4



:: iBSS for n82ap, Copyright 2010, Apple Inc.


:: BUILD_TAG: iBoot-931.71.16





C05C127D0F IBFL:00 SRNM:[838316YHY7K]



Entering recovery mode, starting command prompt

] printenv

] setenv auto-boot true

] saveenv

] fsboot

] \exit

] \reboot

] reboot


using the command "printenv" only returns another bracket. As you can see the normal commands don't work. When I enter the last reboot, the iphone is able to shutdown, and the apple logo comes back up and then the screen blanks out again.

Problem may be that it's in DFU mode, not recovery mode.

I'm using the irecovery instructions from here:

If I disconnect the phone, hold down the home button, reconnect the cable, and keep holding, eventually I will get the connect to itunes logo.

I can start iRecovery again, and get the following the same results

**Edited out repeat iRecovery screen**

This again gets the screen blank, and then the apple logo.

If I repeat the process and try an itunes restore, it results in an error 23.

Was this answer helpful?

Score 0


Oldturkey recently put a link of what to repair for error 23- just take a quick look at posts over the last week or search error 23 at top of page. Good luck.


Thanks Pollytintop for the reference. I think you're referring to this picture?


Aw crap, I didn't mean to link to the thumbnail, and now I can't find it again.

Here's a link to the 3g parts layout pic. Which one is the "radio"?


Ok, found the oldturkey comment again in I phone wont turn on.Error 23 after battery drained!!

I'm not sure if the whole solution is the 2 parts at the bottom they're talking about reflowing, but it looks like one is the infineon battery charger/usb component. Do you concur? Anyone tried this?


Further research brings up the idea of oven reflowing: or heatgun reflowing (link on previous page.) However, I may wait until the dock connector arrives before I take that step. Anyone tried it? For the heatgun reflow, it appears from the following link that I should be targeting some specific chips: Baseband CPU, Baseband Flash IC & ECID flash IC. I don't know which ones these are. I can ID the baseband cpu, and flash (Nymonux sram) from the board pic I linked above. Not sure which ones are the ECID and Baseband Flash ICs. Tips? Ideas?


Show 4 more comments

Add a comment

Add your answer

repairthat will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 3

All Time: 20,743