Model A1181: 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1386 Questions View all

Optical drive not recognized in 10.6 but works when booted in 10.5

I have a Macbook A1181 with Snow Leopoard installed. The optical drive is not recognized in the OS, but I can boot from it. In fact, I installed another hard drive, installed a new OS (10.5) and the drive is recognized. I have also installed another optical drive with the same results.

I ran the Software Update in 10.6, but no change.

It looks like there is a software problem in the OS. How can I fix the software to recognize the optical drive?

Thanks.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Please give us a history of your MacBook, has the optical drive been replaced before? The last numbers of your serial number? Outside of not being seen, does the drive function properly?

by

I just acquired this system. I don't know if it has been replaced before. Last numbers of serial number: 6HZ5Y. As I mentioned, I can boot from the optical drive. When the system is booted from a different hard drive which I installed Leopard on, the optical drive works.

by

Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Chosen Solution

Well your machine is a 2006 not a 2009.

Apple MacBook "Core 2 Duo" 2.0 13" (White/06) Specs

Identifiers: Late 2006 - MA700LL/A - MacBook2,1 - A1181 - 2121

I would bet that the drive has been replaced with a non-Apple drive. I would venture to guess that the system was installed before the drive change and that a reinstall of the 10.6 with updates will allow you to see the drive.

Was this answer helpful?

Score 1

Comments:

I updated the model on the post.

I replaced the the optical drive from another A1181 and had the same results.

Since I acquired the system without OS install disks, and considering the optical drive worked when I installed Leopard 10.5 on a spare drive, I guess I'll just install 10.5 on the original hard drive.

As a follow-up question: Is there no way to fix these types of software problems other than re-installing the OS?

by

Find out what the drive is when in 10.5 and see if you can locate a Mac driver.

by

The drive has an apple logo. Model UJ-857-C. If it works in 10.5, why would I need to find a Mac driver? It seems to me the problem must be some software corruption. I think the question is how to fix or replace the corrupt driver. Well, for this case, the solution is just academic. I've wiped out the 10.6 installation and I'm installing 10.5. Thanks for the help though.

by

Add a comment

Add your answer

Glen Meiring will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 844