Released alongside the AirPort Extreme base station, this hard drive equipped variant offers 802.11ac speed on a time capsule NAS.

32 Questions View all

Time Capsule not powering on

I've been using this device for about 1 year until one day I found the light blinking amber. The Airport app was reporting the device was overheated. I pulled the plug and waited for it to cool down and when I plugged it back in there was no light at all. All I could hear was the noise of HDD spin up and nothing seemed to work.

It's out of warranty so can't take it to apple.

I cracked it open and found out that the PSU seemed to be functional. I checked the output voltage and it was a solid 12 Volts. But the fan doesn't run at all. I even tried to apply voltage to the fan to see if it runs but it didn't.

I checked the fan socket on the mainboard and 12 Volts appeared on the multi-meter.

Can I be sure that the fan is faulty? Because I don't want waste money on a PSU to find out it was not necessary.

BTW can someone verify that a working TC acts like mine when no fan is connected.

Thank you

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Most Helpful Answer

More likely the fan died here. For about $20 US you should be able to find one.

I don't have a A1470 TC right now but I've had to replace quite a few fan units across the entire line of TC's

Was this answer helpful?

Score 1

Comments:

Do you by any chance remember how the TC acts with a faulty fan?

Thank you

by

Add a comment

Add your answer

shoeib will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 3

Past 30 Days: 9

All Time: 211