A television game console produced by Sony Computer Entertainment, first announced February 20, 2013 and released November 15, 2013.

539 Questions View all

Faulty open button after teardown

I took my PS4 apart to clean out the fan and apply some better thermal paste. All successful, the device powers on and plays games nice and quiet now.

The only problem is the "open" button doesn't work any more. When touching it the CD doesn't eject. I've managed to eject discs by using the manual screw method, but would really like the button to work properly.

I've noticed on the inside of the lower casing there is a small metal contact that seems like it should make contact with something else. I've tried beinding it out a bit and putting it back together, but still doesn't work.

Has anyone had this issue or have any ideas?

Many thanks.

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

2 Answers

Chosen Solution

That metal piece you see contacts the copper pad on the green board on the disc drive. You need to bend it until it makes contact with that pad. I sometimes use a sharpie to color the metal pad then see the where the metal contact goes when I put the case on (there will be a line in the ink). That will tell you which way it needs to be bent.

Hope this helps..good luck!

Was this answer helpful?

Score 2
Add a comment

You can eject the disc by pressing triangle then select remove disc

Was this answer helpful?

Score 1
Add a comment

Add your answer

Sam Attwood will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 2

All Time: 41