13" aluminum unibody, 2.0 or 2.4 GHz Core 2 Duo processor.

576 Questions View all

Ram port not working

Hi folks,

So I have 2x4gb ram sticks with the most updated EFI for my Macbook 5,1.

Put both sticks in and my system information says only 4gb recognized. Removed one stick and tried on both RAM ports. The top port works fine, the bottom port doesn't work and the system won't start and beeps once every few seconds. Has anyone encountered this problem and does anyone have any suggestions as to how to fix it?

Cheers!

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

There are 12 different A1278 models, let's nail yours down. What are the specs on your RAM chips? Are they identical? Do you have the original sticks?

by

Add a comment

2 Answers

Chosen Solution

Hey folks

Thanks for getting back to me.

Just wanted to update everyone to say that I fixed the problem. Looking through the other questions asked I found this

Bank 1 Memory Slot not recognizing RAM--easy way to fix?

And in the comments saw Jay Arvidson had suggested slightly unscrewing the ram slots on the motherboard.

I loosened them ever so slightly and BAM now my computer is running 8gb. Also just upgraded to a SSD and I feel like I'm running a new computer.

Absolutely fantastic stuff.

Thanks for everyone's help!

Was this answer helpful?

Score 1
Add a comment

Hey there Nik.

Sounds like a bad ram slot.

It's made out of many pins, you can look into the slot and make sure the pins are aligned correctly and not bent.

I've fixed a few just by bending the pins back.

There is also an IC chip on the motherboard that may not be working properly. We've repaired issues like this as well.

Gonzalo

-CleverTech

Was this answer helpful?

Score 0
Add a comment

Add your answer

Nik will be eternally grateful.
View Statistics:

Past 24 Hours: 4

Past 7 Days: 9

Past 30 Days: 39

All Time: 400