Skip to main content

Mid 2009 Model A1278 / 2.26 or 2.53 GHz Core 2 Duo processor EMC 2326

870 Questions View all

Bank 1 Memory Slot not recognizing RAM--easy way to fix?

It seems as though my Bank 1 Memory Slot is not recognizing any RAM I put in it. Here is what I've done so far to identify the problem:

-Computer is agonizingly slow. I order two 4GB sticks of RAM from iFixit, and install the RAM without issues.

-Boot computer, and it's now running much faster. However, it shows in System Information that there is only 4GB of RAM recognized, and Bank 1 slot shows as empty.

-I switch the RAM sticks between Bank 1 and Bank 0, computer boots just fine but still shows Bank 1 slot empty.

-Put old RAM sticks in. Bank 1 slot shows as empty.

-Restart with just one stick of RAM in Bank 1, computer beeps but is unable to start.

I'm thinking that Bank 1 died before I even bought new RAM--this would explain why even just recognizing one stick of RAM would improve the speed of my computer. Is there anything I can do to get my computer to recognize Bank 1? Some Google searches suggested loosening the screws around the bank, but this did not help me. Any other suggestions?

Answered! View the answer I have this problem too

Is this a good question?

Score 3
Add a comment

MacBook Battery Fix Kits

Starting at $69.99

Buy Now

MacBook Battery Fix Kits

Starting at $69.99

Buy Now

3 Answers

Chosen Solution

Sorry no - replace the logic board or, as a work around, run on one RAM chip.

If this answer is acceptable please remember to return and mark it.

Was this answer helpful?

Score 1

Comments:

no way to execute some chip-level repair?

by

The RAM socket would need to be removed and replaced as its damaged. This level of repair can't be done by a DIY person as you need specialized equipment to remove the socket so as not to damage the logic board and you also need access to the part which is not easy in this case as the part is not available.

See if loosing the screws de-stresses the board enough to allow the socket to work. Otherwise you'll need to replace the logic board. Then is it worth doing given he age of the system?

by

Add a comment
Most Helpful Answer

slightly undue the screws near the memory slots on the motherboard, there are 3. should fix the fault most of the time.

Was this answer helpful?

Score 14

Comments:

This totally worked for me (after checking after I posted my own question) Thanks Jay Arvidson!

If you want to copy and past your answer on my question I am happy to rep you up

Ram port not working

by

THIS WORKED!!!!!!!!!! Thank you so much.

by

God level ! It worked !

by

I've had this problem on two different MacBook Pros. Came across this answer (thanks Google!) and it worked like a charm. This after months of not having a solution.

by

I'm looking for the screws to loosen, i only see two (i think). It is an image step 34 of the disassembly guide, i loosened ~6 screws all at the bottom of the logic board.

Issue resolved

by

Show 5 more comments

Add a comment

(graveyard post… i know, sorry)

Only tighten mounting screws down enough to make them snug, never over tighten as this can flex the board, damage traces or cause short to ground faults.

Also, some of these boards have RAM compatibility issues, always double check the manufactures website to verify that the memory you intend on using is supported by the board. Generally, unsupported RAM may work but can be unstable, entirely unsupported RAM will generally cause a power on - no POST (if powering on at all). This also includes checking your BIOS version and update it to current if required.

(!!—never flash for the sake of flashing; if you don’t know what you’re doing you’ll brick your board —!!)

Thirdly, reseatting the memory is always good practice as sometimes the contacts are not aligned or properly touching.

Finally it can come from the CPU as the clock has to synchronize with the RAM timing/clock. Failing to do so will either render the machine with a power no post or will be highly unstable. If you ever have a system you’re having issues with and believe it to be the board or CPU, the best way to test (b/c MOBOs have no real easy way to straight test it, it is either open or closed.) is to remove the memory entirely with only CPU connected. Turn the machine on and if it generates beep error codes, the board is functioning and looking to synchronize the CPU with the RAM. If not, then you are looking at a bad CPU or MOBO. The only way to really determine that is to use a test CPU supported by the board, putting memory and test CPU in, if the machine successfully POSTs, then we know its the CPU and not the motherboard.

Just throwing this out there for extra information, have fun!

Was this answer helpful?

Score 0
Add a comment

Add your answer

Michelle will be eternally grateful.
View Statistics:

Past 24 Hours: 31

Past 7 Days: 260

Past 30 Days: 1,130

All Time: 52,347