Replaced logic board now it doesn't boot past grey screen

I bought refurbished logic board that was said to have come directly from Apple as surplus. It looked great in original Apple bag. I installed the board and before I put the top case down, since it is the most difficult part of the process, I put in memory and the battery and pressed the power button. I got the bong sound from boot up but it just sits at a grey desktop. I don't get the Apple symbol and it does not come up.

Is there something else I have to do? Do I need to boot from the install DVD the first time? IF so what are the keyboard commands to do that I can't seem to get the right ones for this powerbook.

Any help is greatly appreciated.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Turns out it was the hard drive not spinning up. I fumbled it when putting it back in and dropped it about two inches to the desk, which shouldn't have hurt it but.....oh well. Guess I get an upgrade.

Thanks for the quick responses.

by

Add a comment

2 Answers

Chosen Solution

I would try resetting the PMU and PRAM before doing anything else. I am including a link on resetting. Good luck. Ralph

http://support.apple.com/kb/HT1431

http://support.apple.com/kb/HT1379

Was this answer helpful?

Score 2
Add a comment

Also, be sure to check the display data cable's connection to the logic board (indicated in step 21 here). The display data cable provides picture, so a grey screen can be indicative of a bad connection.

Was this answer helpful?

Score 2

Comments:

Sound advice--if the resets don't work recheck the connection. Ralph +

by

Add a comment

Add your answer

Craig Beveridge will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 1,022