New internal hdd problems

I just purchased a new Samsung HM641JI hard drive to replace my old 250gb fujitsu hd.

The problem is, if I put the new samsung hdd inside and try to do a clean install of snow leopard, the setup always hangs at "extracting essentials" and I have to keep the shutdown button pressed to close my laptop.

I thought I have a ram problem or that my dvd is busted but that's not the case because I inserted the samsung hdd in an enclosure, connected it via usb and the install went just fine.

After the setup was over I rebooted a couple of times (still in usb enclosure) and everything was fine but after I inserted it in my mac everything went crazy: excruciating slow boot and runtime. I repeated the process twice to be sure.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

when the new hd was in the usb enclosure, the setup was fast and everything was ok

but! when I put the new hd inside the laptop and tried to install the setup froze at extracting essentials.pkg every time I tried.

So, the install disk is OK.

by

Does your original drive still work properly? Ralph

by

solved the problem. the culprit was the efi 1.7 update. after I downgraded to 1.6 everything was ok

by

Add a comment

1 Answer

Chosen Solution

Take a close look at your installation disk for scratches and/or dirt. This is the first instance I've heard of 10.6 hanging. I would also reformat the new drive and zero it out to insure you are not trying to write to bad blocks. When finished give it one partition.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Mihai Radu will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 1,211