Unrecognized battery after HDD and RAM upgrade

After everything done, following your guide. The mac is working properly, except for the battery, that is working, as i can sometimes turn on the mac, with a loud fan noise on battery mode.

With AC power connected it runs good, but there's a cross on the battery indicator, indicating that there no battery.

How can i solve this? what steps should i follow exactly to make my battery recognizable again?

(tried already some solutions, on plugging/unplugging the battery connector with and without AC power plugged in)

Thanks in Advance

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

Is the X red or black?

by

Did you solve that? i have exactaly the same problem on the same model

by

Add a comment

2 Answers

it's black;

update: the apple hardware test don't recognize any problem. Tried several ways to do de SMC reset, with no results whatsoever (that includes the shift+ctrl+cmf+power several ways; and the unplugging of the battery connector, followed by the "battery reset" (if i can call it so...)

i still think the battery alive, since i've managed to turn on the pc on battery twice (thus the cross was still there, and the fan's were working at full speed)

Was this answer helpful?

Score 0
Add a comment

Hi, I have the same problem!

Did you solved it? How?

Thanks

Fra

Was this answer helpful?

Score 0
Add a comment

Add your answer

Luis Andre will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 168