The Samsung Galaxy S4, model i9505, features a 13-megapixel rear camera, and a 5-inch 1080p display.

591 Questions View all

GPS fault after Samsung Galaxy S4 Display Assembly Replacement

Hi,

Followed the guide here: Samsung Galaxy S4 Display Assembly Replacement

Awesome easy!

All went to plan without any issues with the work however the GPS is now not working correctly. I would like to know what parts/cables I should be looking at to check for lose connections etc.

Any ideas...?

Answer this question I have this problem too

Is this a good question?

Score 6

Comments:

I've opened the device up again however no lose connection. Come on guys! For all I know the screens part of the gps and I purchase a DOA part! What parts should I replace if the GPS don't work anymore...

by

Quickest solution I found was selling it on ebay and buying a new Galaxy S5... :) Still I want to know what caused this...

by

FYI: http://allaboutgalaxys4.com/galaxy-s4-on...

Shows you the GPS atenna location.

by

Just check your power saving status. If it is on than just switch off. Than check your gps fix ;)

by

Add a comment

20 Answers

Most Helpful Answer

try to see if you forgat a screw, or if there a lose screw in the phone, i know there is a problem with the screwes in s3..

i have the same problem in s4 and i saw they forgot a screw in the right side of the phone(silver screw). i'm waiting for a new screw.

Was this answer helpful?

Score 2

Comments:

Update:

it turns out, that the screen was probably defected and influenced gps and wifi, tew weeks after i replaces the screen the thouch stoped working, then they replaced the screen again and the gps and wifi started working perfectly!

by

Brilliant I took my phone apart a half dozen times convinced I missed something. I ordered another replacement and returned the old. Worked perfect GPS and WiFi are both normal. I guess there is something in the assembly for the antenna.

by

Add a comment

In my case the problem was conductive rubber seal on magnesium mid frame that bears motherboard all around. On original screen this seal was very well conductive. On replacement screen (ordered from China Alliexpress) there is nonconductive seal from silicone rubber adhesive.

The solution is to cut original seal very gently. Than cut silicon rubber seal from replacement screen and place original seal in it.

See the difference (replacement part with extracted original seal laying on it):

https://goo.gl/photos/WVab9a73274yNryA9

There was the problem with interferences on screen while calling too. It is gone now .

Was this answer helpful?

Score 2

Comments:

Thank you very much for your solution! I tried everything, and it worked by replacing the conductive rubber (replacement screen as well). I only replaced the small track of conductive rubber on the corner above left - thats the place, where the GPS antenna is.

by

I'm gonna try your solution on my S4. How can I attach the original seal?

What type of glue did you use?

by

Add a comment

Yep, opened it up, everything looks fine. Same deal as Anthony, no GPS and spotty Wifi

Was this answer helpful?

Score 1
Add a comment

I replaced the antenna today and no dice, so based on your experience and mine, that's clearly not the issue. Really frustrating as I use my GPS a lot.

Was this answer helpful?

Score 1

Comments:

My fix was very simple. I removed the back-lid and tighten all the visible screws. After this my GPS was up and running. I tried a lot of Apps but none could get more than a couple satellites on board. Any GPS fix or accuracy was non existent and google maps was lagging all the time and putting the map backwards or sideways, missing roads etc.. This happened some time after getting my display replaced for a new one and been driving with a Smartphone holder (which vibrates quite a bit). So i'm guessing the guys at the shop did some sloppy work at tightening the screws and the holder in my car took care of the rest.

Saludos, Uber driver.

by

Add a comment

(fixed)

SCH-i545 Same issue, completed my 5th screen replacement on this phone (the previous 4 replacements completed in years past... I've broken this phone and replaced nearly half of the parts in it.)

I tried everything, I mean every single fix I could find including painstakingly removing the rubber seal on the midframe and replacing it with the one from the previously working screen just like David suggested. I tried to put folded up tinfoil in places to make sure everything was completely connected but in the end the solution was that the GPS spring had been slightly impacted (which I guess is easy to do if you press it with your finger or if the board is installed without everything being aligned properly). I used a thin needle and slid it parallel to the surface of the motherboard to get in-between the spring (not a traditional spring, it's more like a loop in the shape of a shoe/boot) which caused the spring to pop back up. Now it properly connects to the GPS antenna on the inside of the rear frame and all is grand.

  • There are a total of 6 of these springs on the motherboard (4 small, 2 large for wireless charging) make sure all of them are not impacted/smashed down.

GPS Spring

GPS Spring

Cheers is this helps and sorry for the long read and the time wasted if it didn't!

Was this answer helpful?

Score 1

Comments:

holly $@$* this works!!! I would have never thought about this. thank you so much sir. me and my wallet thank you.

by

Add a comment

There are many Galaxy S4 hardware models, just "Galaxy S4" is not clear enough.

I have the service manual for GT-i9500, if you have the correct model i can try to provide troubleshooting.

Was this answer helpful?

Score 0

Comments:

The model is GT-I9505

by

Add a comment

Did you ever get a resolution for this? I'm in exactly the same situation, everything but the !@#$ GPS is working. Any update appreciated.

Dave

Was this answer helpful?

Score 0

Comments:

Hi Dave,

No Answer yet.... did you also open the device up?

by

Add a comment

I have a sch-i545 with the same issue. I replaced the display panel now have no gps fix and weak WIFI. I did a factory reset just to be sure but still no go. Any suggestions?

Was this answer helpful?

Score 0
Add a comment

I ordered a new antenna (mine has 2, one white and the other red), so I'll see if that helps

Was this answer helpful?

Score 0
Add a comment

I had another working i545 that swapped the two antennas (red and white wires) with and no change. My working phone still had normal GPS WIFI and the one with the replaced screen has no GPS and spotty wifi. I also tried prying up the little gold contacts scattered around the boards that make contact to the case with no change.

Right now I just hope my wife doesn't get lost and needs her GPS.

Was this answer helpful?

Score 0
Add a comment

Same problem here (GT-i9505). No GPS and crappy WiFi connection. I reseted it twice, I tighten all the screws, I shouted, I cried and nothing. It's so disappointing, I wanted to wait for the S6 but maybe it's time to change it.

It would be awesome if somebody finds a solution for this problem soon...

Cheers,

Was this answer helpful?

Score 0

Comments:

I opened it completely, tighten hard every screw and it's working again. GPS is perfect but wifi, despite working, it's not as good as before changing the screen...

by

Add a comment

I think you should check where the motherboard interfaces with the plastic mid frame. I think the GPS antennae is in the little plastic cutout just to the left where you see the micro sd label on the mid frame- this has to connect via a spring contact on the motherboard- these spring contacts may be your issue

Was this answer helpful?

Score 0

Comments:

Ok I think I figured out which contact it is (I337 version)- looking from the back its the spring contact in the uppermost left hand side (the one I mentioned above is the wifi contact). Check this one - also its important to make sure the motherboard has a good ground connection so check the contact area where the black screw is

by

Add a comment

I tightened the screw better (the black one inside the phone at the right) and now it's working fine.

Was this answer helpful?

Score 0
Add a comment

i have this exact same issue, has anyone found a solution?

i've tried tightening all screws wit no success... unlike some others mentioned here my LTE and my WIFI signals are perfectly fine, just 0 GPS.

Was this answer helpful?

Score 0
Add a comment

Downloaded a GPS test app that updated the aGPS data and all is working now.

Was this answer helpful?

Score 0
Add a comment

I have s4 i9500. Wifi is working properly but gps is not fixing. The gps testing software show that there are 27 satellites but not fixing and didnot getting the position. I did factory rest on my phone but problem is still exist. Any one please give me some suggestions.

Was this answer helpful?

Score 0

Comments:

Hi..I have the same problem. only gps issue. 15-25 Sat detection..but they lost tracking. Did you get some solution?

by

Add a comment

I got a used i9500, and after installing 5.0.1 Lollipop on it thought that the GPS problems (sees few satellites, and of the ones that it sees can't get a fix) were related to the experimental nature of the 5.0.1 ROM. After reading this thread about tightening the screws, thought - what the heck, can't hurt - tightened all the screws and bang! perfectly working GPS. Unbelievable! Just my 2c for posterity... Thanks, guys!!!

Was this answer helpful?

Score 0
Add a comment

Tried everything and $@$*! Nothing works plus memory card is not accepted by my S4 GT 19505!

Now sold it and bought another one for £80 on Ebay!

Was this answer helpful?

Score 0
Add a comment

My fix was very simple. I removed the back-lid and tighten all the visible screws. After this my GPS was up and running. I tried a lot of Apps but none could get more than a couple satellites on board. Any GPS fix or accuracy was non existent and google maps was lagging all the time and putting the map backwards or sideways, missing roads etc.. This happened some time after getting my display replaced for a new one and been driving with a Smartphone holder (which vibrates quite a bit). So i'm guessing the guys at the shop did some sloppy work at tightening the screws and the holder in my car took care of the rest.

Saludos, Uber driver.

Was this answer helpful?

Score 0
Add a comment

I just fixed this problem on my Samsung Galaxy S4. Check for loose screws first and if it does not fix the problem, Follow these steps on this YouTube Video owned and uploaded by outie555:

https://www.youtube.com/watch?v=kMNb8BVr...

Enjoy!!

Was this answer helpful?

Score 0
Add a comment

Add your answer

AceCrosley will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 23

Past 30 Days: 96

All Time: 15,916