Model A1181: 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1378 Questions View all

DC in board Problem

My battery wasn't charging so I decided to replace dc in board . But It isnt disconnecting from logic board . Is it attached with glue or something .. I have tried alot but not disconnecting.. Is there any particular way to unplug it ??

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

The A1181 MacBooks don't have a DC in board as such unlike the A1342 MacBook model. The connector is soldered to the main logic board.

Did you try cleaning the connects and check to see if a second power adapter with Isopropyl alcohol and cotton swabs (Q-Tip)?

I suspect you have a burnt FET which is a common issue. Static discharge (ESD) often kills them.

Was this answer helpful?

Score 2

Comments:

The A1181 and the A1342 have the same DC in socket soldered to the logic board and use the same black connector type.

by

lemerise - the Unibody models have a plug in Mag-Safe connector unlike the older Poly-Carb units. Checkout this pic DC-in board connector

by

I haven't tried anything yet . Can you please tell me how to clean it .

by

And what is its solution?? What do i do now ?

by

Samuillah - Sorry to say you can't replace the Mag-Save connector on this model as its part of the logic board. You will need to replace the logic board if the connector is damaged.

by

Show 8 more comments

Add a comment

Add your answer

Samiullah will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 118