Why no power after replacing Mag In-Board

Long Story Long! Spilled wine on computer; took it apart immediately, wiped it down, threw it into a bag of rice and waited a day. Hooray, it powered up using battery and worked fine. Waited too long, however, to test power adapter, which did not work (N.B. it was starting to go anyway). Took it to Apple and was told it was the Mag In-Board (gave me a new power cord because of strain). Apple refused to consider repair since they detected the liquid damage. Decided to replace in-board myself and ordered part and two screw drivers from ifixit. Read Guide and then some silly advice from two users to skip steps between 6 and 18. That didn't work so had to start from beginning. Finished and it lighted up (flashing green, with occasional amber) I was delighted. But . . . doesn't power on. If I remove battery connector from logic board light turns to amber so it is connecting. Read further and decided I reattached cable ribbon incorrectly and took Mac apart again--almost impossible job getting ribbon in slot and I may have damaged it (is it blue on underside as I seem to be missing a piece that's in picture?). Also, I can't reattach speakers, both, second time around. Probably broke the connectors. Did an SMS, nothing. Battery was completely drained when I started--could that be the problem? Anyway, if it doesn't work within two days, I'm selling it for parts. As an aside piece of advice. Please, don't listen to users who tell you not to follow guide! You must remove logic board to change the Mag in-board.

HELP!

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Seems to be a common trait - DIYers looking for shortcuts, or who "read" but don't "study" guide directions & comments thereby doing more damage to their devices. If you damaged the cable time will not heal it... some tape or silicone might You could possibly replace the cables. Remembering the cam locks and coated or plastic tweezers can be useful in working with ribbon cable.

by

I studied the guide extensively and once upon a time actually wrote user manuals for Bell Labs, among other telecoms, and complained bitterly when users wouldn't read them. So perhaps this is my punishment! But since two users, one seemingly knowledgeable, suggested it would be better to skip certain steps that are very delicate and likely to cause problems, I tried the short cut. Unfortunately very delicate was correct, so I lost connections to speakers as well as having issues with ribbon cable--I think. It was very very short to I had to pull in with some strength to get it to fit inside connection. Would you know if the ribbon cable is blue on the inside top? I'm even wondering if it is the ribbon cable I attached. Sigh!

by

How about a link to the guide you used (I'd like to see these comments), plus the last three figures of your serial number so we know your correct machine.

by

Guide: Replacing McBook Unibody ModelA1342 MagSafe Board- iFixit

Opened it up again to check if perhaps the ribbon connector or some part was stuck under logic board, but it was not. It's about 1/4-1/2 inch in length and just fits into the connector but with pulling and pushing and using the back side of an emery board to push it in, it's connected. I can see pressure spots on the ribbon, however.

Lemerise.m suggested going directly to Step 19. Can't find the post of the other user but he/she said skipped from Step 6 to 18 with success.

In my most recent iteration of opening my computer (just now) I apparently knocked out another connector, for LED sleep. I tried two pins as someone suggested, a very very small flat screwdriver, my finger nails, etc.

Still with blinking bright green light (occasionally amber blinks) unless I disconnect the battery connector in which case I have all amber blinks. That would suggest that I'm getting power, I believe.

by

Add a comment

1 Answer

Chosen Solution

Amber= Your battery is charging but possibly has not yet reached a full charge state.

If this Answer is helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 1
Add a comment

Add your answer

gracebrophy will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 118