Model A1181: 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1369 Questions View all

MacBook 5.1 temperature sensor missing?

Picked up a Macbook to fix the other day and started to clean the internals as they were very dusty. Cleaning around the heatsink and noticed a connector on the board without any cable connected labelled "temp".

No obvious cable anywhere to connect and cant find anything relating to it in any disassembly guides.

Im guessing there was one there and needed but not 100% sure.

can anyone help?

Block Image

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

On the early 2009 MacBook 820-2496-A logic board, the J5520 connects the CPU/MCP Thermal Sensor. It looks like this one http://www.ebay.com/itm/Apple-MacBook-A1...

by

Add a comment

3 Answers

Chosen Solution

I don't think there is a sensor on all models... you gave a very generic model description (there's 5 builds in that series) but from this picture sequence for the fan replacement it doesn't appear to me that anything was attached to that connector block.

If this answer was helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 1
Add a comment

I have a MacBook 5,2 and I opened it up last week to clean the internals and replace the thermal compound. I've got the same "missing" temperature sensor as well — at least now I know I'm not alone. I also noticed a screw or two missing that were supposed to be holding the fan in place; not sure if they fell out or the tech forgot to put them back in when I sent my MacBook to have the top/bottom case and speakers replaced a couple of years back, but everything seems to work fine.

Was this answer helpful?

Score 0
Add a comment

Hello I have the same issue with that kind of logic board. So i look for it on eBay and found a heatsink like the one I had, with a sensor attached on the picture so I rushed and bought it.

Long story short I receive exactly the same like I had before and NO sensor at all. So I guess there's no sensor at all for that model of logic board. Mine is a early 2009, EMC 2330. A1181 and is the terminal J5520.

Was this answer helpful?

Score 0
Add a comment

Add your answer

kelvin stephenson will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 9

All Time: 790