Released October 2008 / 2.4, 2.53, 2.66, 2.8 or 2.93 GHz Core 2 Duo Processor

399 Questions View all

Super slow SSD in all operations

Macbook Pro 15" Unibody 2.53 GHz Mid 2009

I have three Macbook Pros I use, and had to swap the drives around. In April my old one (pre-unibody 2008) had a hard drive failure so I replaced it with an SSD (Sandisk Ultra Plus). It worked great. Now I'm switching drives around to use the new faster Unibody 2009 MBP with the information on that old MPB's SSD.

Maybe this was stupid, but I was hoping I could just pop the SSD drive in the 2009 and it would work (same OS, Snow Leopard, on both). It actually did boot up and ran all my apps, but very slow! I got the spinning beach ball non-stop. Next time I tried to boot it failed.

So, I tried re-installing the OS from scratch with the SSD in the 2009 MBP. I tried several times and the installation was just taking so long I shut it down. I am currently running Erase again in the disk utility and writing everything to zeros. So far it is about 1/3 done and it's been going for 1/2 hour. This is only a 128GB drive!

It seems like every operation that accesses the SSD from this MBP is super slow. I don't think the problem is the drive. Just yesterday it was working perfectly in the 2008 MPB. I've also read some stuff about faulty SATA cables in the 2009's. I haven't tried any firmware updates or TRIM settings, since I can't even get the OS installed. Not sure what to try next. I can't afford another drive right now.

Thanks

John

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

You could verify it's a cable problem if you put the drive in an external case and see if it' still hangs. If it does it could be that the disk is failing or corrupted.

If this answer was helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 2

Comments:

I'm having the exact same issue; I ordered two 256GB Sandisk Ultra Plus drives, put one in a polycarbonate unibody MacBook and one in a 2009 MacBook Pro, and the 15" that got the SSD is turbo slow! exhibiting the exact same behavior you described. RMA'd the drive, same issue. tried in my 2008 aluminum 13" MacBook and it works perfectly fine! Installed 10.8.4 with TRIM support enabled and put back in the 15", and sadly no difference was made. What the heck is going on here?

by

SATA I/O speed - Depending on your model you will have either a SATA-I/II or SATA-III port and you need to match the port speed with the SSD or get a SSD that can auto sense the port speed.

by

Also you may need to update the EFI firmware Apple TN on EFI updates

by

Well, I have bad news. I finally gave up trying to fix this. I changed the cable, checked the EFI firmware, etc. and everything else everybody recommended all over the internet. The cable helped, but it was still messed up. I kept getting the spinning beach ball. I don't have infinite time to mess with this, so I just bought a regular Western Digital 7200rpm drive. The computer works fine again. I can only guess that the problem was my Sandisk Ultra Plus was a SATA III drive, which the MBP didn't like.

By the way, the Ultra Plus worked great in an external case... absolutely NO problems, except I had to plug in the USB drive all the time!

by

Show 1 more comment

Add a comment

The problem is with this particular (mid 2009) MBP's SATA controller talking to Ultra Plus at 3GB/s (SATA II). They can talk to each other no problems at a reduced speed of 1.5GB/s (SATA I). If you want to continue using this SanDisk, you'll have to DOWNGRADE the MBP's EFI firmware to EFI 1.6.

http://forums.sandisk.com/t5/SanDisk-Ult...

or google:

Downgrade EFI firmware to 1.6

Was this answer helpful?

Score 0
Add a comment

Add your answer

091710 will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 11

Past 30 Days: 33

All Time: 5,258