MacBook Pro 13" Unibody Late 2011

Late 2011 model, A1278 / 2.4 GHz i5 or 2.8 GHz i7 processor.

230 Questions View all

SATA III SSD no longer detected

I have removed my ODD and replaced it with the original hard disk that came with the laptop. I then put the a new OCZ Agility 3 SSD ( in the place of the original hard disk.

This configuration worked for about a year however one time when waking from sleep the screen became jumbled and froze. I left it like this for about 5 minutes and after not responding, i preformed a hard reset (power button for 10 seconds). Upon starting back up, i the SSD was no longer detected, or atleast no bootable OS was found. I then reset the SMC and still had the same issue.

Booting my mountain lion disk's disk utility i then found that the drive was detected (and its smart status OK) however no partition was on the device. Upon trying to format the device misc errors would occur and the device would pop in and out of connected devices. Convinced there was an issue with the device i purchased a new SATA III SSD. This SSD also is not detected.

It is worth while to note that the link speed is 6GB/s which matched the drives transfer rate and this configuration has worked before. I have tried the SSD in the ODD bay as well as the HDD bay and have the same issue.

Ive spoken to a few people and done some research and found a few possible issues.

-logic board defective

-EMI shielding the cable might help

-bios issues. i.e. recent update

Im not really convinced this will fix my problem. do i really need to replace my logic board?

Answered! View the answer I have this problem too

Is this a good question?

Score 1


Read Flogo's answer and my comment and try the recommendations there. Also, check the HDD cable and I would try replacing that first as it's an inexpensive fix. Then you can rule out SSD firmware and cable issues first before troubleshooting the logic board.

by Majesty

Add a comment

4 Answers

Chosen Solution

Its because OCZ SSD's have problems with any OS that gets installed to it. SSDs are new-ish to the general consumer market and as such have had many faults. One of those is corruption due to improper installation.

OCZ offers a bootable toolbox for their drives, which I recommend running. To format this drive you want to use what is called "Secure Erase"

For whatever reason SSDs do NOT format like normal HDDs and require firmware updates and special "secure" format processes.

Not being a mac guy at heart, I can tell you that it probably has something to do with the firmware on both SSDs.

I hope that this helps, and I could offer you more help if you had a windows based system as I know many different options / fixes to these types of situations.

Good luck!

Was this answer helpful?

Score 2


I agree. I have an OCZ Vertex Max IOPS on the same machine as the OP. I have never had any issues. BUT, you must have the OCZ tools for updating the firmware and other fixes the OCZ team provides. There was a recent fix for most of the OCZ SSD's regarding a Temp sensor fix. You should check your SSD's firmware often and update when necessary. You can find all relevant info on the OCZ site.

by Majesty

I agree, I would start with the OCZ tools to update the firmware of the SSD as well as reformat the SSD and reload your OS back on. If this still failed I would replace the SATA HD drive cable as there have been some issues with some (where you want the SSD to be connected).

by Dan

Add a comment

Sounds to me like the machine is working OK, just the optical bay port seems to have problems. The first thing I would try is replacing the optical drive cable.

Was this answer helpful?

Score 1


Its actually the optical bay, and the hard drive bay that both dont detect it

by Chris Price

Add a comment

Interested by a follow-up, just installed an Agility 3 in a Macbook pro 15'', late 2011.

Just like you, did move the HDD to optical bay, and put the SDD as main drive.

Did a firmware update and temperature sensor mod upon install.

Hope it doesn't fire back at the board!

Some tools, as a side note:

Was this answer helpful?

Score 0
Add a comment

Download the OCZ toolbox and make sure your firmware is updated, then reformat using their tool (not OS-X Disk Utility). Then reload your OS back on. If you have any errors either the SATA cable is damaged or the SSD has a problem. I've had a few SSD's that I had to redo that just gave up or just had gone bad.

Here's a link to the OCZ toolbox Firmware tools

Was this answer helpful?

Score 0
Add a comment

Add your answer

Chris Price will be eternally grateful.

View Statistics:

Past 24 Hours: 1

Past 7 Days: 3

Past 30 Days: 24

All Time: 2,497