Skip to main content

PowerBook G4 (12-in): known good battery unrecognized.

Hello all,

I recently purchased a 12-inch PB-G4 off eBay, with a known (to the seller) good battery. I found upon initial use that the battery did in fact power the laptop, and charge, and I got it up to 23% before I began having problems with it. The problem was one that I've seen from Google is typical of the PB-G4; and that is, that the battery info from the OS X menu bar shows "battery not charging", even though the power adapter is powering the laptop just fine. I have searched this problem pretty thoroughly online, and have yet to find where anyone actually solved it, even though they've tried new batteries, new power adapters, PRAM resets, PMU resets, NVRAM resets, leaving the laptop plugged in, etc., etc., etc.

I myself have tried the following:

  • PRAM reset
  • PMU reset (all 3 different ways to do it)
  • removing/reinserting the battery
  • leaving the laptop plugged in, with battery, for 24 hours
  • draining the battery completely, in an attempt at battery calibration
  • different power adapters (one 45W & one 65W, both known to be good)
  • different operating systems (Leopard and Tiger)

None of the above have made a dent in the problem. In fact, after completely draining the battery (it powered the laptop for a good 20 minutes before finally dying), the battery level info from the menu bar just showed 0%. After a couple days, it just stopped recognizing the battery altogether.

I believe this to have been a good battery; when the problems began I checked the "Power" info in System Profiler, and it showed that the battery was good. I cannot remember the numbers that were displayed for cycles and such, however I do remember that there wasn't anything ridiculous showing there (such as cycle counts in the tens of thousands, which would tend to indicate a bad battery).

So, here's my question: could the problem here (assuming of course that the battery really is good) possibly be a bad DC-to-DC board? I don't know exactly what the DC-to-DC board does, but it's name leads me to suspect that it has something to do with regulating power to & from the battery.

The reason I ask is that in all my googling, I have yet to find anyone who has suggested the DC-to-DC board as the culprit, or anyone who has tried to solve the problem by replacing that part. I have seen numerous suggestions for other things, like replacing the DC-in board, getting a new battery, new AC adapter, etc.; none of which have seemed to work for anybody.

So, before I plunk down $$ for a DC-to-DC board, or a new battery, I thought it might be worth asking the question. Answers?

Answered! View the answer I have this problem too

Is this a good question?

Score -1
Add a comment

1 Answer

Chosen Solution

Sometimes a little knowledge can be dangerous. The reason you haven't found anything on the DC-to-DC board is that I have no idea what that part might be. Try downloading Coconut Battery (an older version that runs on your machine) to get a very good idea of its status. Next try replacing the DC-IN board. Her's the part: [linked product missing or disabled: IF153-021]

Was this answer helpful?

Score 2

1 Comment:

Hello, thanks for your reply. I appreciate that you're trying to help, but my "little knowledge" that you're referring to came directly from this site. I'd never heard of a "DC-to-DC Board" either, but if you look at the 12-inch Powerbook repair guide, you'll see it there, plain as day. It's a small removable circuit board with the PB's battery connectors on it, and presumably, the circuitry that controls power to/from the battery as well. I didn't just make that up!


Add a comment

Add your answer

Lin will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 7

All Time: 576