Why is my battery not detected after I replaced harddrive?

I changed my hard disk to SSD from stock HDD 320GB.

I replaced the harddisk by walking out the power connector from socket with a my nails and Philips screwdriver from either sides carefully as illustrated in ifixit. I also cleaned all the areas near the vent with a old toothbrush because of the accumulated dust.

After screwing back , I fired the machine only to find the machine not booting. I then plugged the adapter. It was showing green and the system worked normally.

But on removing the adapter the machine shuts off completely.

Also a black x is seen on the battery indicator. I then opened the machine cover to reaffirm the battery connection but of no use.

Sent it to apple service authorities, (not under warranty)they check by switching batteries but still not recocognized.I DIDN'T,TELL I TRIED REPLACING HARDDISK. BEFORE THIS I REPLACED THE STOCK HDD.

Now telling me the only option is replacing the logic board but cost being the prohibiting factor.

Plz help me regain my laptop.PLZ

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

See this Black x in the battery charge symbol? - may want to recontact Apple. It's entirely possible you damaged the logic board.. maybe you can ask/qualify for a depot repair (best price anywhere).

''If this answer was helpful please remember to return an mark it Accepted.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Dinesh Nambiar will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 970