Early 2011 model, A1278 / 2.3 GHz i5 or 2.7 GHz i7 processor.

562 Questions View all

MBP not starting up after disconnecting battery from logic board?

So yesterday my macbook pro was working perfectly fine nothing wrong with it at all but after i followed the guide on ifixit.com to upgrade ram the computer would not start up unless it was plugged into the magsafe adapter. The led on the charger is always green which i think means that the battery isnt being charged. when i am able to power it up while its charging, in the menu bar the battery icon has an X over it and says no batteries available power source: power adapter.

please help asap as need this computer for school!!

also i have already tried smc reset and pram resets but nothing changes.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

3 Answers

Chosen Solution

I would first disconnect, then reconnect the battery. What color is the X? Please give us the last three figures of your serial number. Look in your system profiler under memory and tell us what your configuration is now. Download and run Coconut battery and let us know your results: http://www.coconut-flavour.com/

Was this answer helpful?

Score 3

Comments:

Yes i have tried disconnecting and reconnecting the battery. The color of the X is just black and doesnt change at all. THe last 3 figures of m y serial number is RJ7, my memory is now 4gb total 2x2gb i undid the upgrade after my computer wouldnt start. and coconut battery shows everything gray and N/A.

by

Apple MacBook Pro "Core i5" 2.3 13" Early 2011 Specs

Identifiers: Early 2011 13" - MC700LL/A - MacBookPro8,1 - A1278 - 2419*

Symptoms

The battery of a MacBook or MacBook Pro computer may:

Appear to have no charge (zero percent)

Be unable to power the computer by itself; the computer might work only when it is connected to the MagSafe power adapter, which only shows a green LED

Appear with a black "X" icon on the menu bar

Note: If a red "X" icon appears on the menu bar and the power adapter displays an amber LED, see MacBook, MacBook Pro, MacBook Air: Battery not recognized after being fully drained instead.

Resolution

Shut down, then remove and reinstall the battery. Test for the issue(s) again.

Connect the MagSafe power adapter (if you haven't already) and see if the behavior continues.

If the issue(s) persist, download and install the Mac OS X v10.4.9 Update.

If the issue(s) persist, download and install Battery Update 1.3.

If, after installing the Mac OS X v10.4.9 Update and Battery Update 1.3, a black "X" still appears in the menu bar, follow the steps in MacBook, MacBook Pro, MacBook Air: Battery not recognized after being fully drained.

If the battery charge status still shows zero percent, yet appears to show a nearly full charge shortly thereafter, see Calibrating your computer's battery for best performance. http://support.apple.com/kb/TS1457

by

Add a comment

Hey, I am having this exact issue after installing a Crucial ssd in my 2011 MacBook Pro. The moment I installed the ssd, and booted it up to install Mac OS, my laptop did not boot on battery power. After I installed Mac OS, I have the 'X' icon on my battery. Tried SMC reset, nothing worked. Checked my battery in a friends laptop and it worked fine. Does anyone have any solutions to this?

Was this answer helpful?

Score 0

Comments:

Same problem appeared after reseating both RAM cards on mid 2010 MacBook Pro 13". Symptoms include:

Sleep light blinks 5 times before booting after pressing the power button (indicating a battery problem), fans run continuously at full power when not in sleep mode, computer runs very slowly (mouse pointer jumping around screen, graphics lag etc.), and the battery icon shows black X. I have tried resetting SMC and PRAM/NVRAM, reseating ram, and replacing the battery ($100 repair). None of this has worked and the symptoms still remain. I hope the problem isn't with the logic board (Even more expensive repair). It is possible I damaged something when reseating the RAM (fixing another problem) by not being careful enough with ESD. Does anyone know what causes this issue? I have guessed battery, logic board, and maybe the DCin board. I really don't have the money to replace the logic board or get a new laptop.

by

Add a comment

I haven't really done much research but the one constant in all of these situations is that in every case the laptop was opened up and some of the parts were changed around. It's possible that in each of these cases the motherboard got a static shock from whoever was opening the laptop and damaged something related to battery charging / management. Right now it's winter and I live in a dry place so it would be really easy to build up a charge.

Was this answer helpful?

Score 0
Add a comment

Add your answer

XPI77 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 5

Past 30 Days: 17

All Time: 2,283