2.2, 2.4, 2.5, or 2.6 GHz Core 2 Duo processor

918 Questions View all

Bad logic board or power supply?

I have a 15'' MacBook Pro, aluminum (A1260 model), and my startup issues are the following: The battery is fully charged and the computer pluged in, attempting to startup has significant problems. There is no chime, and no screen, everything stays black. The status LED is unlight. When the I/O is pressed, the computer breifly attempts to start, then powers off. When held down, the computer begin's it's startup process, the fans start whirring, the optical drive powers up, and the status LED flickers, then before anything can happen the whole unit powers down.

I've tried resetting the SMC, PRAM (which is not possible because the computer does not have a chance to recognize startup commands, the same is true of holding click to release a CD, or firewire mode, or anything else, I've tried them all). How do I determine if I have a bad logic board or a bad power supply? If anyone has had a similar problem or knows what my problem is, help would be greatly appreciated. Thanks in advance.

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

This question was migrated from http://meta.ifixit.com/Answers.

by

Add a comment

1 Answer

Most Helpful Answer

Check the button on your battery. If this model has less than a 20% charge the machine may behave in exactly this manner. Also, what wattage of MagSafe adapter are you using?

Was this answer helpful?

Score 2
Add a comment

Add your answer

Rene Guajardo will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 2

All Time: 1,286