Skip to main content

A1418 / EMC 3069 / 2017 / 3.0 GHz quad-core i5, 3.4 GHz quad-core i5 or 3.6 GHz quad-core i7 Processor. Released June 8, 2017.

176 Questions View all

iMac stuck on Apple logo

Tried installing linux, now i bricked the s*** out of it and no combinations of keys work.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Most Helpful Answer

Do you have access to another Mac system to create a bootable macOS installer so you can run Disk Utility to rebuild your system.

Was this answer helpful?

Score 1

14 Comments:

Yeah, have a macbook pro mid 2012 on ventura

by

Also, no combinations work and already tried the ventura installer on mid 2012 MBP (USB works fine installed macos with it before) and also tried it on the iMac but only boots to apple logo

by

@danial21870 - Did you use the Option key Startup command to select which drive to boot from?


Reference: Mac startup key combinations


If that failed are you even able to enter into diagnostics using the D key?

by

Nope. Still does nothing

by

@danial21870 - Well that sucks! Somehow you messed up your systems firmware is my best guess.

Did you alter anything internally? Switch of the drives or repasted the CPU.

by

Show 9 more comments

Add a comment

Add your answer

Danial will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 11

All Time: 68