Skip to main content

4-inch iPhone released in March 2016 with similar hardware specifications to the 6S. Available in Silver, Space Grey, Gold, or Rose Gold with 16/32/64/128 GB storage options. Model: A1662 and A1723

1053 Questions View all

Battery replacement -> Touch ID failure

Hi all,

I'm asking you here because after replacing the battery of an iPhone SE 2016, even though the home button works, I cannot activate Touch ID.

To replace the battery, I sliced the phone open with a flat head screwdriver and a suction cup. I tried to be careful not to open it too much because of the main button booby trap, and with the same screwdriver, I flicked of the cage that protects the button's ribbon cable's connector; and as it came off, the cable disconnected with it. Again, being careful not to open phone too much (the angle of the screen and the house was always less than 60 degrees), I took out those five of the six screws that hold the metal plates for the battery and the screen connectors; I didn't manage to take out the sixth (it was the top-left for the screen connectors), so I just rotated the metal plate 90 degrees clockwise to access the connectors. I disconnected the battery first and then the three connectors for the screen, and I separated the screen and the chassis. Then I adventurously removed the old battery and replaced it by a new one, screen connectors back (still being careful about the angle of the screen), battery connector back; I didn't reconnect the main button. I switched on the phone to see if it works and it did, so I turned it off again, installed those metal plates back, connected the main button again (took a lot of time), put the cage on it (another 6 hours), switched it on-- and everything worked (even the main button), but not the Touch ID. I tried switching the phone off, reconnecting only that cable, I did it twice, but it didn't solve the problem.

So what do you guys think, how could I fix it? Anyone ever met this problem?

Thank you for your replies in advance!! :)))

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Most Helpful Answer

You probably tugged or pinched the Touch ID cable/connector somehow, can't tell by text description alone, microscopic images will help.

Was this answer helpful?

Score 1
Add a comment

Add your answer

László Magócsi will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 1

Past 30 Days: 7

All Time: 33