Skip to main content

Repair and disassembly information for Google's Pixel 7 Pro smartphone, released in October 2022. Identified by model number GP4BC and GE2AE.

95 Questions View all

Fingerprint reader not working on new screen, how to troubleshoot?

I recently changed the screen of my Pixel 7 Pro, the display and the touch feature both work well; the fingerprint does not.

When I try to setup the Fingerprint Unlock android feature, I immediately get the following error on the Touch and hold the fingerprint sensor screen:

Fingerprint setup timed out
Fingerprint enrollment didn't work. Try again or use a different finger.

Things I tried but didn't fix the issue:

  1. Ran the official repair app on: https://pixelrepair.withgoogle.com/carri... (after successfully pairing with my phone, the app displays an error stating that the software on my phone is newer than that of the tool and is unable to scan it).
  2. Factory reset.
  3. Re-opened the phone and double-checked the screen-to-frame connector.
  4. Doubled-checked the sensor-to-screen connector (came installed but I disconnected and connected it back).
  5. Downloaded and installed the Android USB driver for windows on my PC https://developer.android.com/studio/run...
  6. Successfully ran the Update and Software Repair Tool on https://pixelrepair.withgoogle.com/udfps

None worked, however after doing point 6, the error message takes more time to appear.

Before the new screen I remember my screen would turn very bright white on and around the fingerprint sensor, now it doesn't.

I have the fingerprint sensor from my old screen ready to install on the new screen but before risking damaging the new screen, I thought I asked here:

Is there any other way to troubleshoot the fingerprint reader via software to be sure it's not working?

Answered! View the answer I have this problem too

Is this a good question?

Score 7
3 Comments

tl;dr: The repair tool on chrome will no longer work, you need to move the sensor from your old screen to a new screen.

From what I understand with Android 13 the repair tool stoped working. My repair guy was able to get a new screen that did not have the finger print sensor built in, then he swapped the finger print sensor from the old screen to the new one, and bam it worked!

The first one he gave me had a new fingerprint sensor, I tried everything even loading on the oldest version of Android the Pixel 7 Pro would take and trying the repair tool, and it did not work. Spend hours following different guides, nothing worked. So just bring it back to your repair guy and tell him he will need to move the sensor from the old screen to the new one.

by

This worked for me - https://pixelrepair.withgoogle.com/udfps

Note: I used a Mac to repair the fingerprint reader issue, so I believe this solution is OS independent.

Instead of repairing the fingerprint reader via software, I tried re-installing the software. It didn't work for me the first time but I repeated the same process a second time and it worked like a charm :)

by

what do i do with a zip file there is no exe ??

by

Add a comment

6 Answers

Chosen Solution

This worked for me:

  1. Enable Developer options
  2. Enable debugging
  3. Get the Google USB Driver
  4. Install OEM USB drivers
  5. Run Google Pixel - Update and Software Repair

Was this answer helpful?

Score 18

20 Comments:

Nice find, Eduardo. This is a recurring theme with Pixel fingerprint sensors, so I'm going to bookmark this page for future users who run into the same problem.

Thanks for coming back and letting us know what the solution was!

by

Worked for me too! Thanks Eduardo!

by

wow - thanks for documenting this! So glad I found it.

I was a bit confused about Install OEM USB drivers step, since really this is just the "Install the Google USB Driver you downloaded in step 3 step"

but it was smooth sailing after that - no factory reset/data loss.

did not even have to re-add my old fingerprints, they worked with the new screen/reader.

by

I did all of these steps and the calibration process completes successfully as well but when I try to set up a fingerprint - I still get the error "Fingerprint Sensor Timed out". I am on the pixel 6 pro though.

Anybody else still having these issues?

by

@manasmoothedath

JA , habe das gleiche Problem

by

Show 15 more comments

Add a comment

Hi Eduardo,

How do I replicate steps 3 and 4 on a Macbook?

Was this answer helpful?

Score 0

7 Comments:

You can try it without steps 3 and 4. You shouldn't need the driver for the Chrome on MacOS to detect.

Unfortunately, althought I've successfully calibrated using the tool many times. I have been unable to get it to work on my Pixel 6 Pro

by

Following the instructions, seems like no extra drivers are needed on MacOS that's true. But the fix hasn't worked for me either :I'm starting to think that the sensor is damaged.

by

I too had the same issue (only have a Mac).

This worked for me - https://pixelrepair.withgoogle.com/udfps

by

https://pixelrepair.withgoogle.com/udfps

this also worked for me for pixel 7 pro today with the latest soft. I've tried mutliple other things though so just go through all the steps multiple times and pray

by

This is a comment i`ve found in issuetracker from google and worked for me.

Read carefully.

Make sure you click on the option BELOW that says "fingerprint calibration software"

I was clicking on the software update which is right there when you visit the page https://pixelrepair.withgoogle.com/carri...

However you must SCROLL DOWN.

Make sure you have your phone plugged into your laptop / desktop and have the driver installed, if not install using these steps https://developer.android.com/studio/run...

Make sure you have developer options enabled on the pixel > settings> about BUILD NUMBER (CLICK UNTIL IT SAYS DEVELOPER MODE ENTERED)

Then settings> system> developer options > USB DEBUGGING (ON)

Power off and enter FAST BOOT (hold power and volume for 3 secs)

Go to https://pixelrepair.withgoogle.com/carri... and scroll down and select fingerprint calibration tool.

I was clicking the above option all along and wondering why it wasnt working

by

Show 2 more comments

Add a comment

Hallo,

ich habe auch das Problem, das die Fehlermeldung mit der Zeitüberschreitung kommt. Abwohl alles erfolgreich gemacht worden ist, so woe oben beschrieben.

Was this answer helpful?

Score 0
Add a comment

Questions for those that successfully made these steps work.

What version of Android were you using? anyone able to run it on v. 13?

Thanks guys!

Was this answer helpful?

Score 0

1 Comment:

So that you know, I bought a new screen from iFixIt, followed the procedure and it worked on the first attempt. I'm now using Android v14, security update from Oct/05.2023.

Just wanted you guys to be aware that it finally worked for me following these steps.

Thanks!

by

Add a comment

I am stuck on the last step that says UNABLE TO CONNECT TO DEVICE.

Why is that? i made sure i had the phone in fastboot mode.

Was this answer helpful?

Score 0
Add a comment

to get mine to work I had to follow the steps on here but then it wouldn't connect device so I went to device manager (right click the windows logo then select device manager)

then expand your USB section at the bottom look for the one that says generic usb hub - right click - select update driver let it go to windows update then scroll down to advanced options left click

scroll down to additional options click optional updates then select the one that has 'android fastboot' in the title click it download it then try to connect your phone

Was this answer helpful?

Score 0
Add a comment

Add your answer

Eduardo CGZ will be eternally grateful.
View Statistics:

Past 24 Hours: 18

Past 7 Days: 92

Past 30 Days: 391

All Time: 10,470