Skip to main content

Repair and disassembly information for Google's Pixel 7 Pro smartphone, released in October 2022. Identified by model number GP4BC and GE2AE.

49 Questions View all

Fingerprint sensor not working after screen replacement.


I recently replaced my screen and everything seems to be working as expected, except for the fingerprint sensor. If I try to register my digits I get the following error.

Fingerprint setup timed out

Fingerprint enrollment didn't work. Try again or use a different finger.

Can someone help me out with this?

Answered! View the answer I have this problem too

Is this a good question?

Score 6

I found a workaround to this problem, and have posted that workaround on the Google forums here:


IfThe solution that finally worked was

1. Disable face recognition

2. Go to finger print recognition and It'll work

3. Redo face recognition


Add a comment

2 Answers

Chosen Solution

Assuming there is no fault with the parts used, you'll need to run Google's repair tool, it's pretty simple to use but does require a computer running windows.

The program should walk you through it step by step, but essentially, you'll need to download the software, launch your phone into fastboot, and connect it via a sync+charge cable to your computer (the one included with your phone should work, however some third party ones do not)

There's some debate over whether or not this requires a factory reset, and while I don't believe it does, always make sure to backup your phone before doing any kind of debugging.


Was this answer helpful?

Score 3


I tried this solution and it still does not work. When you try to set up fingerprint, you get error "fingerprint error timed out"


I have the same issue, new "official" screen from ifixit but fingerprint sensor times out immediately. Tried the pixelrepair url, it ran but did not fix the issue.


Install ADB drivers and put usb debugging on. Look on reddit. I did it with the google pxil repair tool. My new screen has now a good sensor again.


Sorry for the late response. I followed Rowdy de Bever's suggestion and it worked! These are the instructions I followed to get it working.

Hope this helps 🙂


I followed the reddit post that Jordan Martinez posted and it worked like a charm!!


Show 5 more comments

Add a comment

Easier solution found after the message "fingerprint set up timed out".

In Face and Fingerprint Unlock

1. Deactivate facial recognition.

2. Go into fingerprint set up. And away you go.

3. Set up facial recognition. Bingo!

Was this answer helpful?

Score 0

1 Comment:

Sorry, but it didn't worked for me :(


Add a comment

Add your answer

Jordan Martinez will be eternally grateful.
View Statistics:

Past 24 Hours: 31

Past 7 Days: 359

Past 30 Days: 1,532

All Time: 7,845