Skip to main content

Fix Your Stuff

Right to Repair


2.26 or 2.4 GHz / White plastic unibody enclosure

751 Questions View all

Why 8GB RAM upgrade failed? (Computer sees only 4GB)


So I've decided to put 8GB RAM instead of 2GB available on start in my Macbook Mid-2010 A1342 (White). After reading this page: What is the maximum RAM for a MacBook Unibody A1342?

as one user suggested it should work I put:

2x Kingston 4GB SODIMM KVR1066D3S7/4G, rated 1066MHz into My MacBook. It sees only 4GB after boot. Bank 1 is filled and Bank 0 is empty. I checked each RAM separately in the bottom bank and it works. In upper bank it gives just beeps. No clue what went wrong - I see lots of stuff that people are capable of making A1342 8GB RAM machine.

Please help me!



Answered! View the answer I have this problem too

Is this a good question?

Score 2
Add a comment


Save by fixing with an all-in-one kit.

Shop iPhone Fix Kits


Save by fixing with an all-in-one kit.

Shop iPhone Fix Kits

1 Answer

Chosen Solution

Your slot may be dead. I have also seen slots that will take a lessor amount of RAM, so use the 4 in the working slot and try one of the older smaller sticks in the bad slot.

Was this answer helpful?

Score 5


+ Good advice mayer. @ Andrzej Sitek1 Did you have both RAM banks filled prior to the upgrade? Have you tried your old RAM in the slot that is not recognizing the 4gb chips? What is the specs on the RAM you replaced? What are the last 3 characters of your serial number?


@mayer - you might be right. I did some tests: I tried both 4GB RAM in either slot separately. My new RAM is ok because in both cases bank 1 is filled. But When I tried the same ram sticks in Bank 0 it gave beep error and didn't start. I've tried to put old samsung 2x1GB configuration but it detected only 1GB in Bank 1. I tried to put 1GB in Bank 0 and start the Macbook - it beeps, so it seems that one of the slots died:( I'm still on AppleCare so I hope they'll help me.

@ABCelars - I've put ram that's according to Apple specs of 204-pins, 1066Hz, SODIMM, DDR3 so it should work.. As I pointed earlier I tried the old RAM and the slot still doesn't recognize it. Right now I can't check the last three chars of my serial, but what for?


Try a 2gb RAM. I know with my macbook I could only have a max of 4gb, so maybe that is the same case for you.


Add a comment

Add your answer

Andrzej Sitek will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 1

Past 30 Days: 3

All Time: 3,607