Skip to main content

In June 2017 Apple updated its 13" MacBook Air with a newer Broadwell Intel Core i5 processor, resulting in slightly increased performance and battery life.

383 Questions View all

MacBook Air 2017 SSD change and compatibility

I know it should be possible but I tried two ssd nvme and two adaptadors (4possibilities).

When booting into recovery there is no internal drive showing up.

I tried with Intel 670p 512GB and Crucial P2 1To...

I have no more drive to try and the disk I find in example are hard to get now...

Any advice?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

You need to create a bootable OS installer thumb drive with High Sierra or newer as these macOS’s offer the needed NVM driver. What you are likely facing is the fact the internet recovery or your current OS is Sierra or older so they don’t have the needed driver.

To get you started plug in a 32GB thumb drive or larger. Now restart your system not Internet recovery. Using the disk Utility it offers in the menus format the USB drive and then install the OS to it. Reboot your system off of the USB drive and now go to this site How to Download MacOS Installers for New & Old Versions to get the desired macOS. Update your USB drive or setup a second USB thumb drive (which is what I would do to be safe). Then after updating the thumb drive install the desired internal SSD, restart the system now with the High Sierra or newer USB drive and now format the internal SSD with the USBs Disk Utility and the. Install the os once more this time on the internal drive.

Was this answer helpful?

Score 1


Thanks for your answer it looks like to be spot on. The bios is indeed running El capitan X on recovery, which if understand well is missing driver to recognize newer drives.

However I am suffering building the usb stick.

Yesterday I could not get to have the correct proposition for the format (no APFS, MacOs with or without Caps, ExFat fat32).

Then I tried transmac and did a format to mac. After that in the mac I could properly format. I tried twice with a 128gb pen drive it goes pretty fast un the beggining then get stuck for hour.

Today I am trying with a 64GB stick, pretty fast in the beggining then I am now at an hour in the last minute step, pretty frustrating.

The macbook is currently running Monterrey 12.6.1 I have downloaded 12.6.2 and this what I am trying to transfer to the Usb.

Is there an alternate way to format the pendrive through windows/linux and get ready to roll? TransMac offers me to flash dmg to the stick but my understanding is limited here as to what would be a good working image.

Other than that I could get a 32gb stick but why would it change much?

I feel I am too far but it is getting frustrating.

Thanks for your help.


@loopingz - I’ve never was able to get TransMac to work setting up a bootable OS installer drive no matter the drive or it’s size. You really need to use a Mac.

The first step is making sure the drive is not improperly formatted. You need to start off with GUID with a journaled file system (HFS+) the OS installer needs this format to work.

Maybe you can get someone local who has a Mac to help you incase yours had a problem with its USB port,


Well I will try this way. Unfortunately I only have a 2011 macbook around but I will find someone!


I have followed that to create the USB:

I was doing it wrong.

Also to format the USB by changing the view type I can properly create the good partition each time. With USB on, installing MacOs on the new disk was fast then getting the time machine worked flawlessly.


Add a comment

Add your answer

looping z will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 6

Past 30 Days: 16

All Time: 62