Skip to main content

Model A1418 / Late 2013 / 2.7 & 2.9 GHz Core i5 or 3.1 GHz Core i7 Processor

254 Questions View all

Have vertical gray area from top to bottom, rest of screen works fine

Block Image

. This is what it looks like. Rest of screen works and if you can "guess" under the gray, can click/select the item. Have done all the usual resets, etc. also changed the display cable. Probably something in display... can that be fixed or have to be replaced?

Update (06/17/2022)

Block Image

So next time I fired the iMac up, it was not an all gray area, but partial top and bottom with a thin blue vertical line. So I used a screen grab of the area, including the missing data part) and it showed up fine. That should mean it is the display is defective. Sadly will order a replacement. Hope this is the right solution. Any comments folks?

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

2 Answers

Most Helpful Answer

@macman67 your screen lost complete contact with the ribbon cable that is coming from the driver board to the display. Since those are attached via a special bonding process, it is not a good DIY’er repair. Yes, replacing the display will be the prudent thing to do

Was this answer helpful?

Score 2

1 Comment:

Experienced repair, so will give it a try. Also order a replacement screen. Thanks.

by

Add a comment

Thanks, heat "rebonded" the cable on that section and all is well again. Thanks!

Was this answer helpful?

Score 0
Add a comment

Add your answer

Carl Schultz will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 76