Model A1174 with 2 GHz Core Duo or Model A1207 with 2.16 or 2.33 GHz Core 2 Duo

271 Questions View all

Will not read install disc just spits it out

Just got an iMac from my dad. It is an older one but he never had any problems with it. I purchased the snow leopard upgrade and have been attempting to install it. The drive just sounds like it is trying to read it and spits it out. This was an issue when I was trying to burn files to a disk to save for my dad prior to the install, but after putting them back in a few times it ended up working. This is not the case with the install disk! I have tried multiple times. It did load once, said I had to restart my computer (which I did), after the restart it spit it out again and wouldn't read it. I am so frustrated! Not sure what else to do at this point... Any suggestions?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

You can replace the drive or, better yet, get an external DVD drive that you can use on other machines. I personally like the LaCie drives, USB/Firewire dual layer.

Was this answer helpful?

Score 4
Add a comment

Have you tried to start-up the machine from your Snow Leopard Install Disc? Is Snow Leopard already installed on the machine or is it running Leopard? If it is, you may have to upgrade to the most recent version of Leopard before you install Snow Leopard. It's not always a hardware problem. HTH ;P

Was this answer helpful?

Score 1
Add a comment

Add your answer

Kelly will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 870