Skip to main content

Slim, lightweight and stylish, the Swift 3 is the ideal laptop for working on the move. The latest NVIDIA® GPU, Intel® CPU and long battery life are housed inside a choice of displays: an elegantly silver chassis with a 13.5” 3:2 ratio 2256x1504 IPS VertiView Display or the vivid colors of a 14” 16:9 FHD IPS display.

13 Questions View all

My laptop won’t turn on and is flashing orange lights

On my Acer laptop there is two orange flashing lights on the side, it won’t turn on, I’ve tried turning off all power adapters and holding it down for 30 seconds. Nothing has worked and it’s still not turning on, can someone please help me

Answer this question I have this problem too

Is this a good question?

Score 2
1 Comment

Werkt bij mijn niet Ik heb ook geen batterij reset

by

Add a comment

2 Answers

Most Helpful Answer

When the battery charge is low the orange light will blink slowly. When the battery charge level is critically low (less than 3%) the orange light will blink rapidly.

But in your case it is fully discharged.  So please follow the steps below

If the battery is not charging with the AC Adapter, perform a power reset:

  1. Remove the battery and unplug the AC adapter or the power cord from the computer.
  2. Press and hold down the power button on the computer down for 30 seconds and then release the button.
  3. Plug in the AC adapter or power cord again, reinsert the battery, and power on the computer.

If the Battery is non removable
Turn off the computer.  Unplug the power cable.   Turn the laptop upside down.
If your system has a battery pinhole reset on the bottom, insert a small paperclip in the battery reset pinhole and hold the button down for 5 seconds.
Connect the power cable and turn on the computer.

Was this answer helpful?

Score 5

2 Comments:

thank you very much. it helped me a lot.

by

Yep worked geat on one Acer but not on second one, so new battery ordered off Flebay..!

by

Add a comment

We had this problem on an Acer Nitro 515-54, nothing worked to fix it. THEN we looked at the BIOS and it was on version 1.01. Downloaded 1.33 BIOS and it fixed the problem. Good Lord! Really Acer?

Was this answer helpful?

Score 0
Add a comment

Add your answer

Potato Potato will be eternally grateful.
View Statistics:

Past 24 Hours: 128

Past 7 Days: 731

Past 30 Days: 3,521

All Time: 27,407