Skip to main content

Released September 16, 2016. Models A1661, A1784, and A1785. Available in 32, 128, or 256 GB configurations in Rose gold, gold, silver, black, jet black, and (Product)Red.

1217 Questions View all

iPhone 7 Plus does not charge or connect to computer after cleaning

Hello:

My iPhone 7 Plus recently was dropped in salt water. I continued to use it for about a day (it's supposed to be good for 30 minutes in 1m of water right!?!?) until it went into a boot loop.

I opened it up and cleaned it out. There was some corrosion at the top in the rear camera socket and antennae. But all seemed to be contained to this upper area. No signs that it got near the Logic board. Once satisfied with cleaning it, I powered it back up and was able to charge it. Only thing was that it was getting pretty hot pretty quickly.

So I then soaked the logic board in 99% isopropyl alcohol for about 15 minutes and then let it dry overnight. I re-assembled it and it works perfectly now... Except it does not charge or be recognized by a computer.

The phone however recognizes that it’s got a cable attached to it as it will power on when plugged in (if off) or if it’s on it will vibrate and the notification saying “Unlock iPhone to use this accessory” pops up.

I have re-seated the lightning connector to the logic board a few times now. It’s not that. I cleaned out the lightning port and the lightning connector. Nothing. I am stumped. I’ve come to the conclusion that it’s either:

  • Lightning port is corroded beyond repair or the lightning module is busted;
  • Dunking the Logic board fried the Tristar/U2/IC chip; or
  • There’s more damage from the salt water that I can’t see.

Took it to a local repair shop and we’re going to try a new lightning module tomorrow to see if that works. If not, I’m not sure what to do…

Thanks.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Found a way to charge it. If it is turned off, it will charge, albeit slowly. It's drawing 0.43-0.44 amps.

by

Camera is getting real hot real quick. Even when it is replaced.

by

Add a comment

2 Answers

Chosen Solution

Try replacing the above part and see if it works, I dont recall properly as to what is that antenna. If i do recall i’ll be suree to update it here. I think its a nfc antenna but I may be wrong.

Was this answer helpful?

Score 0

Comments:

Ordered the part. NFC would make sense. I never use it. Kinda surprising how little information is available for it. Will report back. Thanks.

by

Wasn't convinced this part was the only culprit as right underneath the camera lens was getting pretty hot pretty fast. Suspecting a short, I took the shield off and found a short on C7514_RF and possibly C7512_RF. Both of which are part of the NFC front-end.

by

Got the part in. This is what did it. So far it seems to work now. Thanks.

by

Add a comment

If I disconnect the “antenna flex cable”, this thing:

Block Image

Then the phone works perfectly. It charges and connects to the computer.

I’ve cleaned this thing out thoroughly, cleaned the contacts, re-seated it multiple times. Yet, it will not work. I also can’t find much information on it. What does it do? Seems to be some component of the WiFi, yet the WiFi works perfectly on the phone with it disconnected.

UPDATE:

The phone would get real hot real quick even with this thing disconnected. Looks like the camera is heating up real quick real hot. Even when I replace it, it is quite hot.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Django will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 17