Skip to main content

Model A1311 / Mid 2011 / 2.5 & 2.7 GHz Core i5 or 2.8 GHz Core i7 Processor

425 Questions View all

No SATA, no USB? Never seen this before!

Ok, so I picked up a cheap 21.5” mid 2011 i5. Seller listed it as graphics problem and HDD removed.

Firstly before doing anything I removed the glass and lcd screws to peek inside before attempting power on, all cables were connected and confirmed HDD was removed. Bracket and screws were included in the purchase.

Powered on iMac to find candy cane vertical lines and flashing ? folder as expected.

I replaced the GPU and connected my test SSD with HS installed which is my regular procedure when testing iMacs for refurb.

To my surprise the mac booted to the ? folder again but the screen is absolutely beautiful crisp white, replacement GPU is fine.

OK I'll option/alt with my trusty HS 3.0 USB that works in a dozen others refurbs i have done.

Connected genuine apple USB keyboard booted Mac, boot chime, alt, nothing …… ? folder. Tried another genuine USB keyboard, same result, keyboard commands not working, recovery PRAM reset any Keystroke is non effective.

Next I take a cheap $15 Kmart usb wireless dongle keyboard and mouse and try alt/option.

Cheap usb dongle keyboard works, tested usb dongle in all 4 usb ports and it works.

To my surprise no boot disks found but it loads to internet recovery, I enter WiFi password and wait, after a few minutes it loads the Lion recovery image. I select disk utility and there is nothing, no SATA no USB disk even though both are connected?

I teardown the Mac again and check all connections inspect the motherboard for signs of bad components but it looks good. I need to add that this iMac is immaculate, the logic board has never been tampered with as all the original tape is intact and the cables are tight and tucked as if from the factory, if you have worked on iMacs you will know what I mean. I was surprised that the fans were pretty clean of dust, i have seen a lot worse however the ram slots were caked as usual.

Put it all together and boot alt, no disks but boots to internet recovery be again. I check disk utility, same no disks, I insert OEM install DVD for 2010 iMac, it shows in utility (Iknow it won't work to boot iMac as its for Snow Leopard)

I insert a SD card, it mounts but I cannot format or install Lion to it, greyed out in utility and locked in install utility?

Further testing,: tried connecting SSD to the ODD SATA port and not recognised tried USB 2.0 HS boot disk - not recognised. Formatted SD card JHFS+ GUID in another iMac - detected but still locked, tried CMD/Option R doesn’t ask for WiFi password, loading bar with globe then hangs on Apple icon left it for hours just in case.

Tried CMD R, boots the internet recovery but its booted to High Sierra version not Lion (confused?)

Tried numerous different ram stick pairings and Configs, all work, boot chimes as normal.

Tried connecting to all 3 SATA ports on the logic board, tried all USB ports with HS boot USB.

Tried NVRAM reset, 1,2,3,4,5 times in a row and individually, nada, no difference. SMC reset - no difference.

Loaded genuine apple hardware diagnostics DVD and ran full long test, no error except for HDD temp sensor as expected as SSD connected.

So here I am stumped! I have repaired over a dozen iMacs with way more serious problems than the flashing folder ?.

My only way forward is to believe that the SATA and USB controller has failed but why does the USB mouse/keyboard dongle work?

My second thought is the EFI boot rom is buggered up? Or there was previously a EFI bios password lock but it is not prompting me to unlock anywhere (clue to this is the SD card being locked?)

In the AHT it listed the bootrom as current 82.0 0.0.0

After extensive Google and iFixit searches I have come up empty handed on this one.

I would appreciate if anyone else has observed this behaviour in a iMac and if they were able to resolve it.


EDIT: Can't post pics in comments so adding here.

Block Image

Block Image

Block Image

Block Image

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

I think you’re fighting a firmware issue. Don’t forget the newer OS’s use APFS and from High Sierra onward the OS installer updates the firmware to allow APFS boot up.

So your system might be already updated and the drive (or boot up image) is unable to handle it as its older than High Sierra.

I’ve also seen master boot records message up by malware! Often happens with dual boot or BootCamp based macs running <cough!> Windows!

You may want to take the drive our and using a Windows or Linux system reformat it to FAT or exFAT so Mac Disk Utility is able to handle the drive when you put it back.

Was this answer helpful?

Score 0


That's what I initially thought but I assume when the apple hardware test reports the bootrom firmware as 82.. that the firmware is up to date.

Out of interest I also tried a USB Linux boot disk used for flashing GPUs, it uses GRUB 2.0 and boots in all the iMacs I used it in from 2009-2011, it is also not detected on ALT boot picker.

It also doesn't explain why I cannot format a SD card from recovery disk utility (all options greyed out) SD card was originally FAT 32 and as I mentioned was identified as locked when in JHFS format.

USB boot disk is HS, SSD is also HS, Terminal diskutil also shows no drives except the internet recovery partition and the SD card, all options to partition or format the SD card in terminal fail.

I was hoping last resort to at least install HS to the SD and boot the OS so I can look through SYS profiler to see if it reporting SATA and USB interface hardware.


Currently installing HS onto the SD card in a 27" 2010, will see if I can boot from it in this problematic 21.5 2011, fingers crossed it will help me to get to the bottom if this.

I should also mention a new usb 2.0 fat 32 formatted drive also is not detected in disk utility.


Successfully installed HS to a 32gb SD using the 2010 iMac.

On ALT SD card presents as a boot option on the 21.5" 2011.

First attempt to boot to SD HS hung at 100% loading, hard shut down reboot and managed to load HS from the SD.

As suspected disk utility still shows no disks except the SD, however it looks like the SATA controller and USB controller are working as they are displayed in SYS profiler

At this point I have a SSD on SATA 1 internal AFPS with HS, a HS usb 3.0 external USB connected a FAT32 USB connected external and the SD card running HS.

I have a feeling the logic boards boot rom chip firmware is corrupt, crazy this is 2 in a row for me, last time on a 27" it killed the SD card reader!

Updating HS currently but as the system is already in i think this won't fix the issue and as USB is not working for disks my Lion bootable USB is of no help.

If the HS update doesn't help i will try to make a bootable Lion DVD as I know the optical drive works.


Add a comment

Add your answer

Jesse will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 1

Past 30 Days: 2

All Time: 71