TouchID refusing to register fingerprints after battery replacement

I’ve bought recently one of these devices, and required a battery replacement, so I’ve decided to bring it to my pc master to replace it, and when I’ve received the Mac back, I’ve noticed that it doesn’t detect my fingerprint anymore, so I decided to check the fingerprints menu, and noticed that my only fingerprint was missing.

On attempt of adding a new one, the `Fingerprint limit reached.` error popped up. Also I’ve tried to check one of the checkboxes displayed below the list with the supposedly registered fingerprints, and it redirected me to the fingerprint registration screen, but the message from the image below popped up.

Block Image

So, now I’m not able to use my fingerprint scanner anymore.

From what I tried to do was

  • Entering in recovery mode terminal and typing the `xartutil —erase-all` command
  • Performing a fresh install of MacOS

Unfortunately, none of these methods didn’t help me, so now my mac still cannot read fingerprints. My master told me that maybe he didn’t connect correctly the TouchID flex cable, and that can be the explanation of why the TouchID is giving the errors, but we cannot check this idea right now, so I’m asking here to find some other ideas (if there are any) of why the Touch ID isn’t working now.


I’d take apart the MacBook myself and check everything, but analysing the take apart guides on this model, I’m afraid of breaking anything else, so I’m leaving it intact for the time…

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment