Mid 2006 / model number A1181 / black or white case / 1.83 or 2.0 GHz Intel Core Duo processor.

516 Questions View all

Upgraded My Macboook Core Duo To 802.11n, Why I Can't Turn On Airport?

I'm using a Macbook 1.1 with Snow Leopard 10.6.4. I got a Apple MacBook Pro 802.11n Airport Card BCM94321MC to replace my Standard Atheros 802.11g card. My 802.11g works after waking up from sleep with no problem, but the 802.11n Airport card tries to connect, fails and is unable to be turned on, especially after its turned off.

It shows up in System Profiler As:

Card Type: AirPort Extreme (0x14E4, 0x8C)

Firmware Version: Broadcom BCM43xx 1.0 (

Locale: FCC

Country Code: X0

Supported PHY Modes: 802.11 a/b/g/n

Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 149, 153, 157, 161, 165

Wake On Wireless: Supported

Status: Off

This is what I've tried so far:

1. Connect to network via Ethernet.

2. Go to Network in System Preferences.

3. Select AirPort and under the gear dropdown choose Make Service Inactive.

4. Hit the plus and add a new AirPort service (Airport 2 or whatever).

5. In the Advanced tab add the name of the wireless network you wish to join.

6. Hit Apply.

7. After a few moments, the new service found my network. I deleted the "original" Airport service and renamed the new one to Airport.

Try doing a Parameter RAM reset - hold down apple/option/p/r keys at start up and wait for three chimes before releasing the keys.

I have tried removing battery, does not work.

Tried reseting the SMC, didn't work.

Tried deleting /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist and restarting. Also tried deleting the entire contents of the /Library/Preferences/SystemConfiguration folder.

tried booting to the 10.6 DVD (holding down C as it restarts) and surprisingly enough there is still no airport support then (no icon in the bar).

putting it to sleep didn't work for me

tried deleting the Automatic location in my Network Preferences and created a new location for Airport, didn't work.

tried taking out the card, reseting, shutting down, and putting in the card again. didn't work

The card will sometime sporadically turn on and capture networks when i put the computer to sleep and remove the battery, but once it goes to sleep again its back to not allowing me to turn it on. Any help would be much appreciated.

Answered! View the answer I have this problem too

Is this a good question?

Score 0


This might be a dumb question and I am a pc guy but... Did you install the new drivers for the card? Did you download them from Apple update?


Yea, I would need someone more experience with mac to help me with this. I have installed them from Apple update.


surely somebody has had this problem?


Add a comment
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

1 Answer

Chosen Solution

From what I can determine at Mactracker your computer firmware won't go beyond 802g reliably. You would need to update your computer to use 802n. You could check with Apple to see if there is a firmware update to allow the card you want to use. Good luck.

Was this answer helpful?

Score 2
Add a comment

Add your answer

thunderman will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 1,255