Skip to main content

Model A1311 / Mid 2011 / 2.5 & 2.7 GHz Core i5 or 2.8 GHz Core i7 Processor

429 Questions View all

Ubuntu 20.04 bootable usb not showing up


Since my 2011 iMac was struggling to run High Sierra I decided to wipe clean the disk and installed Ubuntu 20.04 in UEFI mode.

Everything works great but later I discovered my HDD has lots of bad sectors and needs replacement. I ordered a replacement SSD but with still original HDD in the machine, I cannot see my ubuntu 20.04 bootable USB in boot options (neither in grub nor using Mac’s Alt option). Any suggestions are welcomed.

Thanks in advance.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer


could you give some information on how you flashed the Ubuntu installer onto your USB device? In my experience it's quite easy to end up with something that just won't work on macs. It's also not super straight forward to create a bootable USB installer on OS X, here's a guide - - that seems to get it right, can't test it myself though as I don't own a a mac any more.

Update (08/17/2020)

All right, I misunderstood your first post a little. Just to be sure, I would definitely try to reset NVRAM and PRAM as detailed here:

If that doesn’t help and you are currently able to boot into Ubuntu (even if only on your HDD with some broken sectors), you could check if the the USB device shows up under the OS correctly (e.g. by executing lsblk) and even just write a fresh Ubuntu installer onto it via the dd command (there’s many guides how to do this online and you don’t need any additional tool to create a bootable USB under linux).

If neither suggestion works I’m afraid you’ll need a more knowledgeable person than I.

Good luck!

Was this answer helpful?

Score 0


Hello, thank you for your response.

I created the bootable USB drive using UnetBootin on MacOS. I used this thumbdrive for initial migration from MacOS to Ubuntu 20.04 wherein this same USB was recognized in MacOS startup menu. After I wiped clean the internal HDD and installed Ubuntu after which I can no longer see that same USB device in startup menu.


I tried resetting NVRAM and PRAM, none of which fixed the issue.

I tried creating a fresh USB for ubuntu using dd, unetbootin, gnome disk creator none of them worked and failed to show up in startup manager.

I tried cloning my existing HDD to USB connected SSD, I kept getting IO error when using linux 'dd' command. even after ignoring errors, machine booted to GRUB from external SSD automatically upon boot without any intervention but failed to boot to OS.

Is there a way to start ubuntu OS installer from ubuntu operating system?


Add a comment

Add your answer

Zeus10 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 9

All Time: 347