New HD not working

Hi,

I just but a new HD for my Macbook Pro 13" from an apple store and my problem was that my computer stopped working or the system booted very slowly. They took the computer in and after one day they told me that the HD was broken.

The HD they gave me is the exact same model of HD that the macbook pro had I followed the guide for installing a new HD exactly the same. But my problem is that while trying to install the OS and running disk utility the HD won't appear. I've read many forums and information about but I can't really understand what's happening.

Thanks

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Your hard drive needs to be formatted before installing a system. Boot from your system installation disk by inserting the disk and restarting holding down the "C" key. Go to the second screen pull down menu to Utilities > Disk Utility. Select your drive in the left hand column and give it one partition. Quit disk utilities and continue with your system installation.

Was this answer helpful?

Score 4

Comments:

the problem is that the disk utility is not recognizing the HD, so I cant give a format to the disk. I just read that I should force the HD to work at 1.5Gbps instead of 3Gbps but I think that unnecessary.

by

Go ahead and use the jumper to to slow it down, we've seen this problem before.

by

I take it the jumper change worked?

by

The jumper change worked, now while I'm at the disk utility I can see the disk. The problem now is that while trying to give a format to the disk I get this error "cannot allocate memory". I think it is related with the RAM.

thou I'm not sure.

by

Last time we ran into this it was a bad hard drive: Cannot format new HDD under 10.6? But make sure you're formatting GUID by giving it one partition

by

Add a comment

Add your answer

luis will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 738