Skip to main content

Fix Your Stuff

Right to Repair

Store

Model A1347 with 2.4 or 2.66 GHz Core 2 Duo Processor.

86 Questions View all

Why is the computer halting?

I have a Mac Mini 2010 running Snow Leopard and installed all updates. I erased the drive and installed a fresh copy of SL including Rosetta and QT 7 then installed all updates.

After the computer boots to the login screen it halts or hangs for 5 minutes. The mouse works but I can’t use the keyboard to enter a UN and PWD. The cursor just sits and blinks at the UN.

Once I get keyboard functionality and after I login then the computer responds I can do what I want.

If I boot into Safe Mode, there are no problems. I can remote into the computer and no problems.

I have tried PRAM and it doesn’t resolve the issue. I ran DU and doesn’t find anything wrong with the drive. There is nothing in the Launch Agents, Daemons or Startup Items.

Besides something possibly hardware related, I don’t know what is causing the halt or hanging at the login screen.

Update (05/25/2020)

Here is an update. I took out the original 320gb drive and replaced it with another drive. Then I performed a fresh SL install and I installed the first set of updates and waiting for it to respond. It is at the desktop and it finally responses to mouse activity when I click on the icons.

After the computers boots it automatically goes to the desktop where it hangs and I can't click on nothing. No icons or anything else.

So far, it still continues to hang with another HD. I would say there is something else that is going on.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Most Helpful Answer

You are facing a tired drive issue. Over time the files on it (OS, Apps & data) get fragmented so it takes a bit of time sometimes for the OS to load as it needs to find all of the pieces which are scattered across your drives patters and tracks. The best thing here is to replace the drive given its age.

Mac mini Mid 2010 Hard Drive Replacement

Make sure the drive you get is able to run at SATA II (3.0 Gb/s) many drives today are SATA III (6.0 Gb/s) and can’t run at SATA II (3.0 Gb/s) speed your system needs to run at. Review the drives spec sheet if it doesn’t state it don’t use it.

Was this answer helpful?

Score 1

Comments:

Thanks for the response. When I go into DU and run Verify Disk, it comes back with no problems. I guess I will swap drives and follow up later.

by

Disk Utility won't tell you how fragmented the drive is. You would need a drive defragmenter app like Drive Genius 5 to show you how bad it is.

Given the age and the likely hood the drive couldn't handle the stress of the defragmenting and having better and bigger drives available (HDDs or SSDs) its just safer to swap it out and then migrate your data over to the drive.

by

Add a comment

Hey, Have you thought about a faulty logic board? either that or a faulty drive like you briefly mentioned in the OP. Just tryna help. Here is a tip, If you have access to a Windows 7-8-10 PC, download Microsoft’s ISO Burn tool, put the ISO on a jump drive, and boot your Mac Mini into windows using Bootcamp. At this point you could run a favorite program of mine called ‘Task Manager’ and check your RAM, GPU, CPU, Drives, and network info, and cross-check them with the spec the Mac had when new. this will uncover dead NAND cells in the SSD through the minor loss of storage and possibly dead RAM modules (RAM Cells/Chips, not the whole stick.) and help out with troubleshooting. if everything is fine, i don’t know what else, but i think there are bad sectors in all the ram (PRAM, DRAM, And bad GPU RAM in the extreme case.) and SSD. hit me back if you figure it out. Good luck.

Was this answer helpful?

Score 0
Add a comment

Add your answer

jkbmjp will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 42