Replaced Battery then screen wont turn on

Replaced the battery using the ifixit guide doing every step. The phone vibrates when plugged in or when the power button is pressed, but the screen is blank.

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

I went through this whole process and I was really happy at how smoothly it went. Previously, I had done it for my 1st gen Pixel and I had a problem getting the screen off using a heat gun. This time, I used the iOpener and it worked great. I got the screen off without any apparent damage.

I did all the rest, no problem. I put it back together and went to test it before replacing the adhesive for the screen. I got the little vibration to let me know it turned on, but NO PICTURE! %#*@, I knew it went too smoothly.

I tried reconnecting the screen, the battery and the charging assembly connector to make sure they were on correctly. No dice. I don’t know if I accidentally disconnected something or nicked the screen circuitry when I was getting it off. I tried connecting my old Pixel 1 cracked screen to see if anything would show up, but that didn’t work either. (I’m not sure if they’re compatible, but the connector is the same.)

Any ideas?

by

@toki08 let it charge for sometime and try hard resetting it (power button & volume up button)

by

I tried the different reset options (power + volume down, power + volume up, long-hold power) and still no picture. Thanks for the suggestion. That's too bad. I guess I'll try a new display assembly. I'll post here on whether it works or not.

by

Add a comment